summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjon2017-02-24 03:37:09 -0500
committerjon2017-02-24 03:40:00 -0500
commitf8bf537c180fc75eb4abdf671d3f764448a5ff41 (patch)
tree9b5b6248ec62fa3386d43750a3deaf825ec08e7e
parentdd782629ba16a5d641585845d02dddef2ee436d5 (diff)
downloadaur-f8bf537c180fc75eb4abdf671d3f764448a5ff41.tar.gz
update to 1.3.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 18 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7812ff02cb6a..2fb9a8abc910 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,16 @@
pkgbase = python2-pydrive
pkgdesc = Google Drive API made easy
- pkgver = 1.0.1
- pkgrel = 1
+ pkgver = 1.3.1
+ pkgrel = 0
url = https://github.com/googledrive/PyDrive
arch = any
license = Apache
makedepends = python2-setuptools
- depends = python2
depends = python2-google-api-python-client
depends = python2-yaml
- depends = python2-six
- depends = python2-uritemplate
- depends = python2-oauth2client
- depends = python2-httplib2
- depends = python2-simplejson
- depends = python2-pyasn1
- depends = python2-pyasn1-modules
- depends = python2-rsa
options = !emptydirs
- source = https://pypi.python.org/packages/source/P/PyDrive/PyDrive-1.0.1.tar.gz
- sha256sums = 5b644a896ee3c53f4d37907c09e514dcf0bfa1ddb2214d408531b57c5232ac81
+ source = https://pypi.python.org/packages/52/e0/0e64788e5dd58ce2d6934549676243dc69d982f198524be9b99e9c2a4fd5/PyDrive-1.3.1.tar.gz#md5=99c51a87c22edaed718b1bc8d00058e9
+ sha256sums = 83890dcc2278081c6e3f6a8da1f8083e25de0bcc8eb7c91374908c5549a20787
pkgname = python2-pydrive
diff --git a/PKGBUILD b/PKGBUILD
index 6f8b2b03ce94..1a191309c748 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
-# Maintainer: Justin Dray <justin@dray.be>
-
-_pkgname=PyDrive
pkgname=python2-pydrive
-pkgver=1.0.1
-pkgrel=1
-pkgdesc="Google Drive API made easy"
+pkgver=1.3.1
+pkgrel=0
+pkgdesc='Google Drive API made easy'
+url='https://github.com/googledrive/PyDrive'
+license=('Apache')
arch=('any')
-depends=('python2' 'python2-google-api-python-client' 'python2-yaml' 'python2-six' 'python2-uritemplate' 'python2-oauth2client' 'python2-httplib2' 'python2-simplejson' 'python2-pyasn1' 'python2-pyasn1-modules' 'python2-rsa')
+depends=('python2-google-api-python-client' 'python2-yaml')
makedepends=('python2-setuptools')
-url="https://github.com/googledrive/PyDrive"
-license=('Apache')
options=(!emptydirs)
-source=("https://pypi.python.org/packages/source/P/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('5b644a896ee3c53f4d37907c09e514dcf0bfa1ddb2214d408531b57c5232ac81')
+source=('https://pypi.python.org/packages/52/e0/0e64788e5dd58ce2d6934549676243dc69d982f198524be9b99e9c2a4fd5/PyDrive-1.3.1.tar.gz#md5=99c51a87c22edaed718b1bc8d00058e9')
+sha256sums=('83890dcc2278081c6e3f6a8da1f8083e25de0bcc8eb7c91374908c5549a20787')
+
build() {
- cd "$srcdir/${_pkgname}-$pkgver"
+ cd "$srcdir/PyDrive-${pkgver}"
- msg 'Building...'
- python2 setup.py build
+ python2 setup.py build
}
+
package() {
- cd "$srcdir/${_pkgname}-$pkgver"
+ cd "${srcdir}/PyDrive-${pkgver}"
- msg 'Installing...'
- python2 setup.py install --root="$pkgdir" --optimize=1
+ python2 setup.py install --optimize=1 "--root=${pkgdir}"
}