summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu2015-06-19 11:53:52 +1000
committerJonathan Liu2015-06-19 11:53:52 +1000
commitf8e45e7b0b6cc0f8f511aba7679730109a2dff44 (patch)
treee0823aa91031c83789e447bd8b2e4c2d521ae5d4
downloadaur-f8e45e7b0b6cc0f8f511aba7679730109a2dff44.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE5
-rw-r--r--PKGBUILD29
-rw-r--r--install-inform7.sh.patch16
5 files changed, 83 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..d589346ff0aa
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = inform7
+ pkgdesc = A design system for interactive fiction based on natural language
+ pkgver = 6L38
+ pkgrel = 1
+ url = http://inform7.com/
+ arch = i686
+ arch = x86_64
+ license = custom:Inform
+ depends = perl
+ source = http://inform7.com/download/content/6L38/I7_6L38_Linux_all.tar.gz
+ source = install-inform7.sh.patch
+ source = LICENSE
+
+pkgname = inform7
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eae1ed4d5c2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = inform7
+ pkgdesc = A design system for interactive fiction based on natural language
+ pkgver = 6L38
+ pkgrel = 1
+ url = http://inform7.com/
+ arch = i686
+ arch = x86_64
+ license = custom:Inform
+ depends = perl
+ source = http://inform7.com/download/content/6L38/I7_6L38_Linux_all.tar.gz
+ source = install-inform7.sh.patch
+ source = LICENSE
+ md5sums = 4f956c36b30dd0f6588cc21e076c72a0
+ md5sums = 647052976b3870e975e069f71f770d20
+ md5sums = a18958ae17bcc3733119cad77376eec5
+
+pkgname = inform7
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f979dc5852cc
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,5 @@
+The command-line tools share the traditional Inform license: they are
+free, and impose no significant restrictions on even commercial use, but
+are not yet open source in the sense of the GPL (even though source code
+is likely to be published in due course): in particular, those wishing
+to develop variant forms must apply for copyright permission.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1d6866a32d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Jonathan Liu <net147@gmail.com>
+pkgname=inform7
+pkgver=6L38
+pkgrel=1
+pkgdesc="A design system for interactive fiction based on natural language"
+arch=('i686' 'x86_64')
+url="http://inform7.com/"
+license=('custom:Inform')
+depends=('perl')
+source=("http://inform7.com/download/content/${pkgver}/I7_${pkgver}_Linux_all.tar.gz"
+ "install-inform7.sh.patch"
+ "LICENSE")
+md5sums=('4f956c36b30dd0f6588cc21e076c72a0'
+ '647052976b3870e975e069f71f770d20'
+ 'a18958ae17bcc3733119cad77376eec5')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/install-inform7.sh.patch"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./install-inform7.sh -p "$pkgdir/usr"
+ mv "${pkgdir}/usr/man" "${pkgdir}/usr/share/"
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/install-inform7.sh.patch b/install-inform7.sh.patch
new file mode 100644
index 000000000000..068bd1e3a7a0
--- /dev/null
+++ b/install-inform7.sh.patch
@@ -0,0 +1,16 @@
+diff -Nur inform7-6L02.orig/install-inform7.sh inform7-6L02/install-inform7.sh
+--- inform7-6L02.orig/install-inform7.sh 2014-05-08 00:48:08.000000000 +1000
++++ inform7-6L02/install-inform7.sh 2014-05-09 23:09:01.626788006 +1000
+@@ -97,10 +97,8 @@
+ tar xzf ${D}/${COMPDEP} || exit 4
+ tar xzf ${D}/${TERPDEP} || exit 4
+
+-if [ "$PREFIX" != "/usr/local" ]; then
+- cmd="s|/usr/local|$PREFIX|;"
+- perl -p -i -e "$cmd" bin/i7 || exit 6
+-fi
++cmd="s|/usr/local|/usr|;"
++perl -p -i -e "$cmd" bin/i7 || exit 6
+
+ cd ${D}
+ exit 0