summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlevinit2017-09-24 02:23:32 +0000
committerlevinit2017-09-24 02:23:32 +0000
commitf8e8f36e50a5bf65740eaf3bef352b07784deb99 (patch)
tree0397ee4ac41f8b5db23f360fffce1bcba23b0013
parent74f5ab0a0bb61b2673d15e98bf03a61140718a21 (diff)
downloadaur-f8e8f36e50a5bf65740eaf3bef352b07784deb99.tar.gz
add prompt info
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD10
-rw-r--r--grub-themes-solarized-dark-materialized.install15
3 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c6ccbcb3033..08ee758725f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = grub-themes-solarized-dark-materialized
pkgver = 1.0
pkgrel = 1
url = https://www.gnome-look.org/p/1180510/
+ install = grub-themes-solarized-dark-materialized.install
arch = any
license = custom
depends = grub
diff --git a/PKGBUILD b/PKGBUILD
index fef7b2bd1016..4963ed03f4e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,18 +10,12 @@ url='https://www.gnome-look.org/p/1180510/'
license=('custom')
depends=('grub')
optdepends=('grub-customizer')
+install=${pkgname}.install
source=('https://dl.opendesktop.org/api/files/download/id/1497095343/Solarized-Dark-Materialized.zip')
md5sums=('SKIP')
package() {
- install -Ddm755 $pkgdir/boot/grub/themes/
+ install -dm755 $pkgdir/boot/grub/themes/
cp $srcdir/$_pkgname $pkgdir/boot/grub/themes/ -r
-
- echo '======='
- echo -e 'You should:\n1. edit\e[36m /etc/default/grub \e[0m,add (or modify) the line \n \e[1m GRUB_THEME="/boot/grub/themes/solarized-dark-materialized/theme.txt"\e[0m'
- echo -e '\e[0m \n2. execute \n \e[1m sudo grub-mkconfig -o /boot/grub/grub.cfg \e[0m after installation.\e[0m'
- echo '----------'
- echo -e 'also you can use a gui app -- \e[1m grub-customizer \e[0m for changing grub'
- echo '======='
}
diff --git a/grub-themes-solarized-dark-materialized.install b/grub-themes-solarized-dark-materialized.install
new file mode 100644
index 000000000000..fdd92ee6d4ec
--- /dev/null
+++ b/grub-themes-solarized-dark-materialized.install
@@ -0,0 +1,15 @@
+read -r -d '' msg << TIPS
+====================================
+You should:\n1. edit\e[36m /etc/default/grub \e[0m,add (or modify) the line \n \e[1m GRUB_THEME="/boot/grub/themes/solarized-dark-materialized/theme.txt"\e[0m
+\e[0m \n2. execute \n \e[1m sudo grub-mkconfig -o /boot/grub/grub.cfg \e[0m after installation.\e[0m
+------------------------------------
+also you can use a gui app -- \e[1m grub-customizer \e[0m for changing grub
+====================================
+TIPS
+post_install(){
+ echo -e $msg
+}
+
+post_upgrade(){
+ echo -e $msg
+}