summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-06-10 09:15:08 +0300
committerAchilleas Pipinellis2015-06-10 09:15:08 +0300
commitf8ed363892b516f88392ccc43b2409d728a6c4a6 (patch)
tree2f78b08a792788eb19ff958fb51390e1db7b07b6
downloadaur-f8ed363892b516f88392ccc43b2409d728a6c4a6.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee47850e4ada
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ruby-net-ssh
+ pkgdesc = Net::SSH: a pure-Ruby implementation of the SSH2 client protocol.
+ pkgver = 2.9.2
+ pkgrel = 1
+ url = https://rubygems.org/gems/net-ssh
+ arch = any
+ license = GPL
+ depends = ruby
+ noextract = net-ssh-2.9.2.gem
+ source = https://rubygems.org/downloads/net-ssh-2.9.2.gem
+ md5sums = ac7574a89e2b422468d98f5387ceb41e
+
+pkgname = ruby-net-ssh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6a7cae5e531
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Achilleas Pipinellis <axilleas at archlinux.info>
+# Contributor: Hyacinthe Cartiaux <hyacinthe.cartiaux (a) free.fr>
+# Contributor: gem2arch 0.1
+pkgname=ruby-net-ssh
+pkgver=2.9.2
+_pkgname="net-ssh"
+pkgrel=1
+pkgdesc="Net::SSH: a pure-Ruby implementation of the SSH2 client protocol."
+arch=(any)
+url="https://rubygems.org/gems/net-ssh"
+license=("GPL")
+depends=('ruby')
+source=(https://rubygems.org/downloads/$_pkgname-$pkgver.gem)
+
+noextract=($_pkgname-$pkgver.gem)
+
+package() {
+ cd $srcdir
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir$_gemdir" ${_pkgname}-$pkgver.gem
+}
+md5sums=('ac7574a89e2b422468d98f5387ceb41e')