summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Van Gestel2020-11-07 07:40:49 +0100
committerMatthias Van Gestel2020-11-07 07:40:49 +0100
commitf8ed9e88063a637964d90ac1f9e8612400f0e0da (patch)
treeffbd3c7132f8d1c930119e24197f208ed716475e
downloadaur-f8ed9e88063a637964d90ac1f9e8612400f0e0da.tar.gz
Initial drop of amxb_pcb-git
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bacb620c1536
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = amxb_pcb-git
+ pkgdesc = Ubus baapi back-end
+ pkgver = v0.5.3.r0.g3b3cace
+ pkgrel = 1
+ url = https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_pcb.git
+ arch = any
+ license = MIT
+ depends = lib_amxc
+ depends = lib_amxp
+ depends = lib_amxd
+ depends = libpcb
+ provides = amxb_pcb
+ provides = amxb_pcb-git
+ conflicts = amxb_pcb
+ conflicts = amxb_pcb-git
+ source = amxb_pcb-git::git+https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_pcb.git#branch=master
+ md5sums = SKIP
+
+pkgname = amxb_pcb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06e70998403c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: fenrig <fenrig.linux at outlook.com>
+pkgname=amxb_pcb-git
+pkgver=v0.5.3.r0.g3b3cace
+pkgrel=1
+pkgdesc="Ubus baapi back-end"
+arch=('any')
+url="https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_pcb.git"
+license=('MIT')
+
+depends=(
+ 'lib_amxc'
+ 'lib_amxp'
+ 'lib_amxd'
+ 'libpcb'
+)
+makedepends=(
+)
+provides=(
+ 'amxb_pcb'
+ 'amxb_pcb-git'
+)
+conflicts=(
+ 'amxb_pcb'
+ 'amxb_pcb-git'
+)
+
+gitbranch="master"
+
+source=("${pkgname}::git+https://gitlab.com/soft.at.home/ambiorix/modules/amxb_backends/amxb_pcb.git#branch=${gitbranch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DEST="${pkgdir}/" INSTALL_LIB_DIR="/lib" install
+}