summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2023-04-24 16:50:48 -0400
committerChris Severance2023-04-24 16:50:48 -0400
commitf9020ae5db616e7158243d14a135587dc606e338 (patch)
treeb3f9d352d6ac26d5d5803cf00506a68ff7dd2fe0
parentab6d3bc775ae3362c8af6312c4f15844c37a50fa (diff)
downloadaur-f9020ae5db616e7158243d14a135587dc606e338.tar.gz
autu: Update to 10.4.0-1 Fix LD_PRELOAD and buildflags
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca7db2bc7fed..392a6ef4449d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,6 +17,7 @@ pkgbase = gcc10
makedepends = python
options = !emptydirs
options = !lto
+ options = !buildflags
source = https://sourceware.org/pub/gcc/releases/gcc-10.4.0/gcc-10.4.0.tar.xz
source = https://sourceware.org/pub/gcc/releases/gcc-10.4.0/gcc-10.4.0.tar.xz.sig
source = https://sourceware.org/pub/gcc/infrastructure/isl-0.24.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index fc13b9386554..de72624586eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ license=(GPL LGPL FDL custom)
url='https://gcc.gnu.org'
makedepends=(binutils doxygen git libmpc python)
checkdepends=(dejagnu inetutils)
-options=(!emptydirs !lto)
+options=(!emptydirs !lto !buildflags)
_libdir=usr/lib/gcc/$CHOST/${pkgver%%+*}
source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz{,.sig}
https://sourceware.org/pub/gcc/infrastructure/isl-${_islver}.tar.bz2
@@ -97,10 +97,11 @@ build() {
--program-suffix=-${_majorver} \
--enable-version-specific-runtime-libs \
--disable-multilib
- make
+ LD_PRELOAD='/usr/lib/libstdc++.so' \
+ make -s
# make documentation
- make -C $CHOST/libstdc++-v3/doc doc-man-doxygen
+ make -s -C $CHOST/libstdc++-v3/doc doc-man-doxygen
}
check() {
@@ -121,6 +122,7 @@ package_gcc10-libs() {
provides=(libgfortran.so libubsan.so libasan.so libtsan.so liblsan.so)
cd gcc-build
+ LD_PRELOAD='/usr/lib/libstdc++.so' \
make -C $CHOST/libgcc DESTDIR="$pkgdir" install-shared
mv "${pkgdir}/${_libdir}"/../lib/* "${pkgdir}/${_libdir}"
rmdir "${pkgdir}/${_libdir}"/../lib