summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2013-10-01 02:46:45 +0200
committerCarsten Teibes2013-10-01 02:46:45 +0200
commitf929ef8609830c9523c6898b1338b36bcaab6b65 (patch)
treed6bf81cd5a00ac88508bdc51016e0a12e8ac1c34
downloadaur-f929ef8609830c9523c6898b1338b36bcaab6b65.tar.gz
[add] methane 1.5.1
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD60
-rw-r--r--methane-clanlib23.patch35
-rw-r--r--methane-nogl1.patch66
-rw-r--r--methane.desktop11
-rw-r--r--methane.pngbin0 -> 3620 bytes
6 files changed, 199 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70d496f887e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = methane
+ pkgdesc = Help the Super Methane Brothers to capture baddies with your gas gun.
+ pkgver = 1.5.1
+ pkgrel = 4
+ url = http://methane.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = clanlib-23
+ source = http://downloads.sourceforge.net/methane/methane-1.5.1.tgz
+ source = methane.desktop
+ source = methane.png
+ source = methane-clanlib23.patch
+ source = methane-nogl1.patch
+ md5sums = 7e4258e326478678c2332388eab2ed14
+ md5sums = ee0ebbf6138142365f5c1a287d1691a6
+ md5sums = a9ec845554b4987c02723b87d308e573
+ md5sums = ca3b7c6d7e959914e086882d40f8d810
+ md5sums = c6237f8fc6ebaa95b0ee7ff1caabe69f
+ sha256sums = ac1de7009e638c784b4d413b56a4387be94a31bd5fe3050db7b51e39ccfdd248
+ sha256sums = cdbd5cbe9af04eff5bd7b8a467bd39fdbdefb77a4728d09347ee09c64d947d17
+ sha256sums = 6c56b025b058a954bd089850dc50f4f25b292da97bbba0d4315db4060152f1fe
+ sha256sums = d7318ef7004cce6bb3de04c76b1d3d15d26265310a5d3938f2efa6c183f4a346
+ sha256sums = 3b2426f27f45b232caf69d21eb1f79e8db3f7041bc6255eb20fe0fc0aae970a5
+
+pkgname = methane
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f72e7395dd9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: carstene1ns <arch carsten-teibes de>
+# Contributor: Dany Martineau <dany.luc.martineau at gmail.com>
+# Contributor: Larryhaja <larryhaja at gmail.com>
+
+pkgname=methane
+pkgver=1.5.1
+pkgrel=4
+pkgdesc="Help the Super Methane Brothers to capture baddies with your gas gun."
+arch=('i686' 'x86_64')
+url="http://methane.sourceforge.net"
+license=('GPL')
+depends=('clanlib-23')
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tgz"
+ "$pkgname.desktop"
+ "$pkgname.png"
+ "$pkgname-clanlib23.patch"
+ "$pkgname-nogl1.patch")
+md5sums=('7e4258e326478678c2332388eab2ed14'
+ 'ee0ebbf6138142365f5c1a287d1691a6'
+ 'a9ec845554b4987c02723b87d308e573'
+ 'ca3b7c6d7e959914e086882d40f8d810'
+ 'c6237f8fc6ebaa95b0ee7ff1caabe69f')
+sha256sums=('ac1de7009e638c784b4d413b56a4387be94a31bd5fe3050db7b51e39ccfdd248'
+ 'cdbd5cbe9af04eff5bd7b8a467bd39fdbdefb77a4728d09347ee09c64d947d17'
+ '6c56b025b058a954bd089850dc50f4f25b292da97bbba0d4315db4060152f1fe'
+ 'd7318ef7004cce6bb3de04c76b1d3d15d26265310a5d3938f2efa6c183f4a346'
+ '3b2426f27f45b232caf69d21eb1f79e8db3f7041bc6255eb20fe0fc0aae970a5')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # clanlib related changes
+ patch -Np1 -i $srcdir/$pkgname-clanlib23.patch
+ # remove opengl1 renderer
+ patch -Np1 -i $srcdir/$pkgname-nogl1.patch
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # remove leftover build dir
+ rm -fR build
+
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ mkdir -p $pkgdir/usr/share/$pkgname
+ mkdir $pkgdir/usr/bin
+
+ # install desktop entry
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $srcdir/$pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+
+ # install data and executable
+ cp -R {resources,docs} $pkgdir/usr/share/$pkgname
+ install -m755 $pkgname $pkgdir/usr/bin
+}
diff --git a/methane-clanlib23.patch b/methane-clanlib23.patch
new file mode 100644
index 000000000000..ac5fd45791ea
--- /dev/null
+++ b/methane-clanlib23.patch
@@ -0,0 +1,35 @@
+diff -ru methane-1.5.1.orig/Makefile methane-1.5.1/Makefile
+--- methane-1.5.1.orig/Makefile 2011-04-05 09:21:14.000000000 +0200
++++ methane-1.5.1/Makefile 2013-09-12 05:07:40.456736802 +0200
+@@ -1,5 +1,5 @@
+-METHANE_FLAGS = -DENABLE_SOUND `pkg-config --cflags clanCore-2.2 clanDisplay-2.2 clanApp-2.2 clanGL-2.2 clanGL1-2.2 clanSWRender-2.2 clanSound-2.2 clanMikMod-2.2`
+-METHANE_LIBS = `pkg-config --libs clanCore-2.2 clanDisplay-2.2 clanApp-2.2 clanGL-2.2 clanGL1-2.2 clanSWRender-2.2 clanSound-2.2 clanMikMod-2.2`
++METHANE_FLAGS = -DENABLE_SOUND `pkg-config --cflags clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
++METHANE_LIBS = `pkg-config --libs clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
+
+ OBJF = build/game.o build/baddie.o build/methane.o build/target.o build/maps.o build/gfxoff.o build/mapdata.o build/objlist.o build/doc.o build/bitdraw.o build/global.o build/suck.o build/power.o build/goodie.o build/bititem.o build/player.o build/weapon.o build/bitgroup.o build/boss.o build/sound.o build/gasobj.o build/misc.o
+
+--- methane-1.5.1.orig/sources/methane.cpp 2011-04-05 09:08:02.000000000 +0200
++++ methane-1.5.1/sources/methane.cpp 2013-09-12 05:09:03.240665466 +0200
+@@ -80,15 +80,15 @@
+ return 0;
+ }
+
+- CL_AutoPtr<CL_SetupSound> setup_sound;
+- CL_AutoPtr<CL_SoundOutput> sound_output;
+- CL_AutoPtr<CL_SetupMikMod> setup_mikmod;
++ CL_UniquePtr<CL_SetupSound> setup_sound;
++ CL_UniquePtr<CL_SoundOutput> sound_output;
++ CL_UniquePtr<CL_SetupMikMod> setup_mikmod;
+
+ if (GLOBAL_SoundEnable)
+ {
+- setup_sound = new CL_SetupSound;
+- sound_output = new CL_SoundOutput(44100);
+- setup_mikmod = new CL_SetupMikMod;
++ setup_sound = cl_move(CL_UniquePtr<CL_SetupSound>(new CL_SetupSound));
++ sound_output = cl_move(CL_UniquePtr<CL_SoundOutput>(new CL_SoundOutput(44100)));
++ setup_mikmod = cl_move(CL_UniquePtr<CL_SetupMikMod>(new CL_SetupMikMod));
+ }
+
+ // Set the video mode
diff --git a/methane-nogl1.patch b/methane-nogl1.patch
new file mode 100644
index 000000000000..06f1ccde355d
--- /dev/null
+++ b/methane-nogl1.patch
@@ -0,0 +1,66 @@
+--- methane-1.5.1.orig/Makefile 2013-09-12 05:07:40.456736802 +0200
++++ methane-1.5.1/Makefile 2013-09-12 05:21:30.747823618 +0200
+@@ -1,5 +1,5 @@
+-METHANE_FLAGS = -DENABLE_SOUND `pkg-config --cflags clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
+-METHANE_LIBS = `pkg-config --libs clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
++METHANE_FLAGS = -DENABLE_SOUND `pkg-config --cflags clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
++METHANE_LIBS = `pkg-config --libs clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
+
+ OBJF = build/game.o build/baddie.o build/methane.o build/target.o build/maps.o build/gfxoff.o build/mapdata.o build/objlist.o build/doc.o build/bitdraw.o build/global.o build/suck.o build/power.o build/goodie.o build/bititem.o build/player.o build/weapon.o build/bitgroup.o build/boss.o build/sound.o build/gasobj.o build/misc.o
+
+--- methane-1.5.1.orig/sources/methane.cpp 2013-09-12 05:09:03.240665466 +0200
++++ methane-1.5.1/sources/methane.cpp 2013-09-12 05:22:43.694862222 +0200
+@@ -17,7 +17,6 @@
+ #include <ClanLib/display.h>
+ #include <ClanLib/swrender.h>
+ #include <ClanLib/gl.h>
+-#include <ClanLib/gl1.h>
+ #include <ClanLib/sound.h>
+ #include <ClanLib/mikmod.h>
+
+@@ -53,7 +52,6 @@
+ try
+ {
+ CL_SetupGL target_opengl2;
+- CL_SetupGL1 target_opengl1;
+ CL_SetupSWRender target_swrender;
+
+ // Since SWRender is compatible and fast - Use that as the default setting options
+@@ -66,9 +64,6 @@
+ case (opengl2):
+ target_opengl2.set_current();
+ break;
+- case (opengl1):
+- target_opengl1.set_current();
+- break;
+ case (swrender):
+ target_swrender.set_current();
+ break;
+@@ -297,11 +292,6 @@
+ LastKey = 0;
+ GLOBAL_RenderTarget = opengl2;
+ }
+- if ( (LastKey == 'e') || (LastKey == 'E') )
+- {
+- LastKey = 0;
+- GLOBAL_RenderTarget = opengl1;
+- }
+ if ( (LastKey == 'r') || (LastKey == 'R') )
+ {
+ LastKey = 0;
+@@ -322,14 +312,7 @@
+ options_font.draw_text(gc, 10, ypos, "OpenGL V2 - Disabled. Press 'W' to select");
+ }
+ ypos += 50;
+- if (GLOBAL_RenderTarget == opengl1)
+- {
+- options_font.draw_text(gc, 10, ypos, "OpenGL V1 - Enabled.");
+- }
+- else
+- {
+- options_font.draw_text(gc, 10, ypos, "OpenGL V1 - Disabled. Press 'E' to select");
+- }
++ options_font.draw_text(gc, 10, ypos, "OpenGL V1 - Not available");
+ ypos += 50;
+ if (GLOBAL_RenderTarget == swrender)
+ {
diff --git a/methane.desktop b/methane.desktop
new file mode 100644
index 000000000000..51f35c38c976
--- /dev/null
+++ b/methane.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Methane
+GenericName=Super Methane Brothers
+Comment=Game in which you use a gas gun to capture baddies.
+Exec=methane
+Icon=methane
+Terminal=false
+StartupNotify=false
+Categories=Game;ArcadeGame;
diff --git a/methane.png b/methane.png
new file mode 100644
index 000000000000..1ef3576da68e
--- /dev/null
+++ b/methane.png
Binary files differ