summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJat2021-08-20 18:24:42 +0800
committerJat2021-08-20 18:25:23 +0800
commitf98435825c47dbcd9875804aa9a178496ee365b9 (patch)
tree9794dac8d2073a8399f11858dc7c12f0637da03b
parent7610dc3c259e4be3f15b5d91f1ee569cec2be81d (diff)
downloadaur-f98435825c47dbcd9875804aa9a178496ee365b9.tar.gz
pulseaudio 15
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD36
-rw-r--r--pulseaudio-module-xrdp.install9
-rw-r--r--xrdp-script.conf2
5 files changed, 39 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edecb64bfd68..1006fde09eaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = pulseaudio-module-xrdp
pkgdesc = PulseAudio modules for xrdp
pkgver = 0.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/neutrinolabs/pulseaudio-module-xrdp
+ install = pulseaudio-module-xrdp.install
arch = i686
arch = x86_64
- license = Apache
- makedepends = git
+ license = LGPL
+ makedepends = meson
+ makedepends = check
+ makedepends = doxygen
+ makedepends = perl-xml-parser
depends = pulseaudio
depends = xrdp
source = pulseaudio-module-xrdp-0.5.tar.gz::https://github.com/neutrinolabs/pulseaudio-module-xrdp/archive/v0.5.tar.gz
- source = git+https://github.com/pulseaudio/pulseaudio.git
- source = xrdp-script.conf
+ source = https://freedesktop.org/software/pulseaudio/releases/pulseaudio-15.0.tar.xz
sha256sums = 2fdda7b21293941dd671ee2a3557b904e3137eec062f4655a247fe60a4f7b0d1
- sha256sums = SKIP
- sha256sums = 4c6e9c0b1eaf66ea6b8574570d89b292b8554d318ad324f3763f837013b9f44f
+ sha256sums = a40b887a3ba98cc26976eb11bdb6613988f145b19024d1b6555c6a03c9cba1a0
pkgname = pulseaudio-module-xrdp
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bb24d62c7d0d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!pulseaudio-module-xrdp.install
diff --git a/PKGBUILD b/PKGBUILD
index a82aa9105c61..64a137fb2a73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,44 +2,40 @@
pkgname=pulseaudio-module-xrdp
pkgver=0.5
-pkgrel=1
+pkgrel=2
pkgdesc="PulseAudio modules for xrdp"
arch=('i686' 'x86_64')
url="https://github.com/neutrinolabs/pulseaudio-module-xrdp"
-license=('Apache')
+license=('LGPL')
depends=('pulseaudio' 'xrdp')
-makedepends=('git')
+makedepends=('meson' 'check' 'doxygen' 'perl-xml-parser')
+install="${pkgname}.install"
+_pulseaudio_ver=$(pulseaudio --version | awk '{print $NF}')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/neutrinolabs/${pkgname}/archive/v${pkgver}.tar.gz"
- "git+https://github.com/pulseaudio/pulseaudio.git"
- "xrdp-script.conf")
+ "https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${_pulseaudio_ver}.tar.xz")
sha256sums=('2fdda7b21293941dd671ee2a3557b904e3137eec062f4655a247fe60a4f7b0d1'
- 'SKIP'
- '4c6e9c0b1eaf66ea6b8574570d89b292b8554d318ad324f3763f837013b9f44f')
+ $(curl -fs "https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${_pulseaudio_ver}.tar.xz.sha256sum" | awk '{print $1}'))
prepare() {
- cd "$srcdir/pulseaudio"
- git checkout v`pkg-config libpulse --modversion|sed 's/[^0-9.]*\([0-9.]*\).*/\1/'`
- NOCONFIGURE=1 ./bootstrap.sh
- ./configure
+ cd "$srcdir/pulseaudio-${_pulseaudio_ver}"
+
+ meson build
+ meson compile -C build
}
build() {
cd "$srcdir/${pkgname}-${pkgver}"
+
+ sed -i '\#-I $(PULSE_DIR)/src#a -I $(PULSE_DIR)/build \\' src/Makefile.am
+
./bootstrap
- ./configure "PULSE_DIR=$srcdir/pulseaudio"
+ ./configure "PULSE_DIR=$srcdir/pulseaudio-${_pulseaudio_ver}"
make
}
package() {
cd "$srcdir/${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir" install
- # This package installs a global drop-in conf for pulseaudio.service to use the xrdp default.pa script instead of
- # the script from the pulseaudio package. If your only desktop sessions will be via xrdp, this should be fine. But
- # if you want to start local sessions too, this will prevent the real audio devices from being detected. If this is
- # a problem for you, delete the drop-in conf file and roll your own solution for loading the xrdp modules for xrdp
- # sessions only (maybe add PULSE_SCRIPT to the user systemd's environment in startwm.sh and create a drop-in for
- # pulseaudio.service that adds PassEnvironment=PULSE_SCRIPT).
- install -Dm644 "$srcdir"/xrdp-script.conf "$pkgdir"/usr/lib/systemd/user/pulseaudio.service.d/xrdp-script.conf
+ make DESTDIR="$pkgdir" install
}
diff --git a/pulseaudio-module-xrdp.install b/pulseaudio-module-xrdp.install
new file mode 100644
index 000000000000..5de9a9a9a65a
--- /dev/null
+++ b/pulseaudio-module-xrdp.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo -e '\033[0;31mRemember to pass the environment' \
+ '"PULSE_SCRIPT=/etc/xrdp/pulse/default.pa" to pulseaudio' \
+ 'to make this module work.\033[0m'
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/xrdp-script.conf b/xrdp-script.conf
deleted file mode 100644
index beb893ab169f..000000000000
--- a/xrdp-script.conf
+++ /dev/null
@@ -1,2 +0,0 @@
-[Service]
-Environment=PULSE_SCRIPT=/etc/xrdp/pulse/default.pa