summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinuxSEAT2018-07-18 14:14:45 +0300
committerlinuxSEAT2018-07-18 14:14:45 +0300
commitf9c1a4c87cc126bf5e3c1bdd7681602db0aae037 (patch)
treed49ebaaed8e488b692ab63b2632be01380b47e55
downloadaur-f9c1a4c87cc126bf5e3c1bdd7681602db0aae037.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb3a125fbfa4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-dtfabric
+ pkgdesc = a project to manage data types and structures
+ pkgver = 20180707
+ pkgrel = 1
+ url = https://github.com/libyal/dtfabric
+ arch = any
+ license = APACHE
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://github.com/libyal/dtfabric/releases/download/20180707/dtfabric-20180707.tar.gz
+ md5sums = 08b4b4ec3fed2a64895a7f420a3e15e9
+
+pkgname = python2-dtfabric
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..315741a9d99e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: linuxSEAT <--put_my_name_here--@gmail.com>
+
+pkgname=python2-dtfabric
+_pkgname=dtfabric
+pkgver=20180707
+pkgrel=1
+pkgdesc="a project to manage data types and structures"
+arch=('any')
+url="https://github.com/libyal/dtfabric"
+license=('APACHE')
+groups=()
+depends=( 'python2')
+makedepends=('python2-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=(https://github.com/libyal/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz)
+md5sums=('08b4b4ec3fed2a64895a7f420a3e15e9')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+# vim:set ts=2 sw=2 et: