summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrealasking2017-08-24 22:05:59 +0800
committerrealasking2017-08-24 22:05:59 +0800
commitf9e61ffd8246055ba47327c68d1ed4740021b085 (patch)
tree991ac3a95ac25f888cb99ea7331e2ee123ec5452
downloadaur-f9e61ffd8246055ba47327c68d1ed4740021b085.tar.gz
fcitx-fbterm
-rw-r--r--.SRCINFO15
-rw-r--r--INSTALL22
-rw-r--r--PKGBUILD40
-rw-r--r--fcitx-fbterm-git.install22
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43526641488a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fcitx-fbterm-git
+ pkgdesc = add fbterm support to fcitx
+ pkgver = 20110825
+ pkgrel = 1
+ url = https://github.com/fcitx/fcitx-fbterm
+ install = fcitx-fbterm-git.install
+ arch = x86_64
+ arch = i686
+ license = GPLv2
+ depends = fbterm-git
+ depends = fcitx
+ provides = fcitx-fbterm
+
+pkgname = fcitx-fbterm-git
+
diff --git a/INSTALL b/INSTALL
new file mode 100644
index 000000000000..5b33c9a69d2a
--- /dev/null
+++ b/INSTALL
@@ -0,0 +1,22 @@
+post_install() {
+ cat <<EOF
+
+Before run this application at first time, please type listed commands below:
+
+sudo gpasswd -a YOUR_USERNAME video
+sudo setcap 'cap_sys_tty_config+ep' /usr/bin/fbterm
+sudo chmod u+s /usr/bin/fbterm
+
+And then add this line to your .fbtermrc:
+
+input-method=fcitx-fbterm
+
+If you want to display and input Chinese characters when you login to the tty without typing a series commands, please add this line to your .bashrc:
+
+[[ \$(tty) == \/dev\/tty[0-9]* ]] && /usr/bin/fbterm && exit
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41a5329d441f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+## Maintainer: realasking
+pkgname=fcitx-fbterm-git
+pkgver=20110825
+pkgrel=1
+pkgdesc='add fbterm support to fcitx'
+arch=(x86_64 i686)
+url='https://github.com/fcitx/fcitx-fbterm'
+license=('GPLv2')
+depends=('fbterm-git' 'fcitx')
+provides=('fcitx-fbterm')
+source=()
+md5sums=()
+install="${pkgname}.install"
+
+_proj=https://github.com/fcitx/fcitx-fbterm.git
+_name=fcitx-fbterm
+
+build() {
+ cd "$srcdir"
+ msg "Starting Git..."
+ if [[ -d "$_proj" ]]; then
+ cd "$_proj"
+ git pull origin
+ else
+ git clone "$_proj" "$_name"
+ fi
+ msg "Project synchronization Finished."
+ msg "Starting build..."
+
+ cd "$_name"
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_name/build"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/fcitx-fbterm-git.install b/fcitx-fbterm-git.install
new file mode 100644
index 000000000000..5b33c9a69d2a
--- /dev/null
+++ b/fcitx-fbterm-git.install
@@ -0,0 +1,22 @@
+post_install() {
+ cat <<EOF
+
+Before run this application at first time, please type listed commands below:
+
+sudo gpasswd -a YOUR_USERNAME video
+sudo setcap 'cap_sys_tty_config+ep' /usr/bin/fbterm
+sudo chmod u+s /usr/bin/fbterm
+
+And then add this line to your .fbtermrc:
+
+input-method=fcitx-fbterm
+
+If you want to display and input Chinese characters when you login to the tty without typing a series commands, please add this line to your .bashrc:
+
+[[ \$(tty) == \/dev\/tty[0-9]* ]] && /usr/bin/fbterm && exit
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}