summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandaruKasa2023-12-27 16:25:23 +0300
committerSandaruKasa2023-12-27 16:25:23 +0300
commitf9f0bbf6bee6f93e3d85db7556db45a551d71bfa (patch)
tree571a7f3d3fd0f418440d198d147bf58295721854
parent412e965648c9ca329339e46dcded9955bc4a499c (diff)
downloadaur-f9f0bbf6bee6f93e3d85db7556db45a551d71bfa.tar.gz
Take over the package and fix it
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD52
3 files changed, 51 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3772ca0dcc7..6c2fb09edfde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,26 @@
pkgbase = tokei-git
pkgdesc = A blazingly fast CLOC(Count Lines Of Code) program
- pkgver = 7.0.1.r17.16d49fc
+ pkgver = 13.0.0_alpha.0.r986.e2625c0
pkgrel = 1
- url = https://github.com/Aaronepower/tokei
+ epoch = 1
+ url = https://github.com/XAMPPRocky/tokei
arch = i686
arch = x86_64
+ arch = aarch64
license = MIT
license = Apache
+ makedepends = git
makedepends = rust
makedepends = cargo
+ makedepends = coreutils
+ makedepends = sed
+ makedepends = gcc
depends = gcc-libs
+ depends = glibc
+ provides = tokei
conflicts = tokei
- source = git+https://github.com/Aaronepower/tokei
- sha512sums = SKIP
+ options = !lto
+ source = tokei::git+https://github.com/XAMPPRocky/tokei.git
+ sha256sums = SKIP
pkgname = tokei-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..28ebd3a7ec56
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.*
+/pkg/
+/src/
+/tokei/
diff --git a/PKGBUILD b/PKGBUILD
index c5a4d09b63f7..40f26bdada78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,50 @@
-# Maintainer: Márton Szabó < echo "bm90cmFtb0B2aXBtYWlsLmh1Cg=="|base64 -d >
+# Maintainer: SandaruKasa <sandarukasa plus aur at ya dot ru>
+# Contributor: Márton Szabó < echo "bm90cmFtb0B2aXBtYWlsLmh1Cg=="|base64 -d >
pkgname=tokei-git
-pkgver=7.0.1.r17.16d49fc
+epoch=1
+pkgver=13.0.0_alpha.0.r986.e2625c0
pkgrel=1
pkgdesc='A blazingly fast CLOC(Count Lines Of Code) program'
-arch=('i686' 'x86_64')
-url="https://github.com/Aaronepower/tokei"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/XAMPPRocky/${pkgname%-git}"
license=('MIT' 'Apache')
-depends=('gcc-libs')
-makedepends=('rust' 'cargo')
-conflicts=('tokei')
-source=("git+https://github.com/Aaronepower/tokei")
-sha512sums=(SKIP)
+makedepends=(git rust cargo coreutils sed gcc)
+options=(!lto)
+depends=(gcc-libs glibc)
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+_git_folder="${pkgname%-git}"
+source=("${_git_folder}::git+$url.git")
+sha256sums=(SKIP)
pkgver() {
- cd "${srcdir}/tokei"
- printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd "${_git_folder}"
+ printf "%s.r%s.%s" \
+ "$(cargo pkgid | cut -d# -f2 | cut -d@ -f2 | cut -d: -f2 | sed 's/-/_/g')" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_git_folder}"
+ cargo fetch --locked --target "${CARCH}-unknown-linux-gnu"
}
build() {
- cd "${srcdir}/tokei"
+ cd "${_git_folder}"
+ export CARGO_TARGET_DIR=./target
+ cargo build --frozen --release --all-features
+}
- cargo build --release
+check() {
+ cd "${_git_folder}"
+ cargo test --frozen --all-features
}
package() {
- cd "${srcdir}/tokei"
-
- install -Dm755 target/release/tokei "${pkgdir}/usr/bin/tokei"
+ cd "${_git_folder}"
+ install -Dm755 target/release/"${pkgname%-git}" -t "$pkgdir/usr/bin/"
- install -Dm644 LICENCE-MIT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
- install -Dm644 LICENCE-APACHE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-APACHE"
+ install -Dm644 LICENCE-MIT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
+ install -Dm644 LICENCE-APACHE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-APACHE"
}