summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredchenjs2019-07-14 01:31:34 +0800
committerredchenjs2019-07-14 01:31:34 +0800
commitf9ff7dda01d184bc4a8141f897b40d05d75f997e (patch)
treef17047eeaa0ad8bbb28c2dd38aaf64effc880886
parent464fe61eec580c6cb53557057cecd83cc370596f (diff)
downloadaur-f9ff7dda01d184bc4a8141f897b40d05d75f997e.tar.gz
fix otc error
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 28 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed6b52ab284d..f787b247fac8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = adobe-source-han-classic-fonts
pkgdesc = Adobe Source Han Fonts with Classic Style Chinese Character
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/adobe-fonts/
arch = any
license = OFL
- source = https://github.com/redchenjs/source-han-serif-classic/raw/master/OTC/SourceHanSerifC.otc
- source = https://github.com/redchenjs/source-han-sans-classic/raw/master/OTC/SourceHanSansC.otc
- source = https://github.com/redchenjs/source-han-mono-classic/raw/master/OTC/SourceHanMonoC.otc
- md5sums = 9ae3d2c20547a0ce31bdbf7d938075d7
- md5sums = 92d6b46fb5133569ccf3c7bf7d6c6b1d
- md5sums = e8e38cd189bc3f4fcce8306fd5f0492b
+ source = git+https://github.com/redchenjs/source-han-serif-classic.git
+ source = git+https://github.com/redchenjs/source-han-sans-classic.git
+ source = git+https://github.com/redchenjs/source-han-mono-classic.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = adobe-source-han-classic-fonts
diff --git a/PKGBUILD b/PKGBUILD
index 93b4bd569ed1..9add26f8cd95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,35 @@
pkgname=adobe-source-han-classic-fonts
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Adobe Source Han Fonts with Classic Style Chinese Character"
arch=('any')
url="https://github.com/adobe-fonts/"
license=('OFL')
source=(
- 'https://github.com/redchenjs/source-han-serif-classic/raw/master/OTC/SourceHanSerifC.otc'
- 'https://github.com/redchenjs/source-han-sans-classic/raw/master/OTC/SourceHanSansC.otc'
- 'https://github.com/redchenjs/source-han-mono-classic/raw/master/OTC/SourceHanMonoC.otc'
+ 'git+https://github.com/redchenjs/source-han-serif-classic.git'
+ 'git+https://github.com/redchenjs/source-han-sans-classic.git'
+ 'git+https://github.com/redchenjs/source-han-mono-classic.git'
)
md5sums=(
- '9ae3d2c20547a0ce31bdbf7d938075d7'
- '92d6b46fb5133569ccf3c7bf7d6c6b1d'
- 'e8e38cd189bc3f4fcce8306fd5f0492b'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
)
package() {
- install -Dm644 "${srcdir}"/SourceHanSerifC.otc \
- "${pkgdir}"/usr/share/fonts/adobe-source-han-classic/SourceHanSerifC.otc
- install -Dm644 "${srcdir}"/SourceHanSansC.otc \
- "${pkgdir}"/usr/share/fonts/adobe-source-han-classic/SourceHanSansC.otc
- install -Dm644 "${srcdir}"/SourceHanMonoC.otc \
- "${pkgdir}"/usr/share/fonts/adobe-source-han-classic/SourceHanMonoC.otc
+ mkdir -p "${pkgdir}"/usr/
+ mkdir -p "${pkgdir}"/usr/share/
+ mkdir -p "${pkgdir}"/usr/share/fonts/
+
+ mkdir -p "${pkgdir}"/usr/share/fonts/adobe-source-han-serif/
+ mkdir -p "${pkgdir}"/usr/share/fonts/adobe-source-han-sans/
+ mkdir -p "${pkgdir}"/usr/share/fonts/adobe-source-han-mono/
+
+ cp -a "${srcdir}"/source-han-serif-classic/*.otf \
+ "${pkgdir}"/usr/share/fonts/adobe-source-han-serif/
+ cp -a "${srcdir}"/source-han-sans-classic/*.otf \
+ "${pkgdir}"/usr/share/fonts/adobe-source-han-sans/
+ cp -a "${srcdir}"/source-han-mono-classic/*.otf \
+ "${pkgdir}"/usr/share/fonts/adobe-source-han-mono/
}