summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2016-05-29 20:22:49 +0200
committerChristian Krause2016-05-29 20:22:49 +0200
commitf9ffa280dc094fac22b42a06adca8b374591e447 (patch)
tree903a2af8597b5c302a7b1cd87e0d2d9ee9860335
parent1697c044fd17ecad05304595cd7101d55443e6f8 (diff)
downloadaur-f9ffa280dc094fac22b42a06adca8b374591e447.tar.gz
bcftools-1.3.1-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
-rw-r--r--makefile-system-htslib.patch79
3 files changed, 25 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bbb79622c3d..ab1d2cdd9a86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
# Generated by mksrcinfo v8
-# Sat Mar 5 10:52:13 UTC 2016
+# Sun May 29 18:21:54 UTC 2016
pkgbase = bcftools
pkgdesc = Reading/writing BCF2/VCF/gVCF files and calling/filtering/summarising SNP and short indel sequence variants
- pkgver = 1.3
- pkgrel = 3
+ pkgver = 1.3.1
+ pkgrel = 1
url = http://samtools.github.io/bcftools/
arch = i686
arch = x86_64
license = GPL
depends = gsl
depends = htslib
- depends = perl
- source = https://github.com/samtools/bcftools/releases/download/1.3/bcftools-1.3.tar.bz2
- source = https://github.com/pd3/bcftools/commit/946b7eea6d699731f72124d87b3176e0ced4d25a.patch
+ source = https://github.com/samtools/bcftools/releases/download/1.3.1/bcftools-1.3.1.tar.bz2
source = makefile-system-htslib.patch
- md5sums = 17f1f7d9e4a03d64a114b43ca896899f
- md5sums = dd48ce1ac8ef91ea409f8f235574de2e
- md5sums = e5145d175dcd242634baf42749b838f0
+ md5sums = 575001e9fca37cab0c7a7287ad4b1cdb
+ md5sums = 3547e133251f4d088cb087019183efa7
pkgname = bcftools
diff --git a/PKGBUILD b/PKGBUILD
index a7c088092ef2..f879c2dc8691 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
pkgname=bcftools
-pkgver=1.3
-pkgrel=3
+pkgver=1.3.1
+pkgrel=1
pkgdesc="Reading/writing BCF2/VCF/gVCF files and calling/filtering/summarising SNP and short indel sequence variants"
arch=('i686' 'x86_64')
url="http://samtools.github.io/bcftools/"
license=('GPL')
-depends=('gsl' 'htslib' 'perl')
+depends=('gsl' 'htslib')
source=(https://github.com/samtools/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2
- https://github.com/pd3/bcftools/commit/946b7eea6d699731f72124d87b3176e0ced4d25a.patch
makefile-system-htslib.patch)
-md5sums=('17f1f7d9e4a03d64a114b43ca896899f'
- 'dd48ce1ac8ef91ea409f8f235574de2e'
- 'e5145d175dcd242634baf42749b838f0')
+md5sums=('575001e9fca37cab0c7a7287ad4b1cdb'
+ '3547e133251f4d088cb087019183efa7')
prepare() {
cd $srcdir/$pkgname-$pkgver
# prevent shipped htslib to be used
- rm -rf htslib-1.3
+ rm -rf htslib-1.3.1
# patch Makefile to make it work with a system-provided htslib
patch -i $srcdir/makefile-system-htslib.patch
-
- # patch gsl >= 2 problem
- patch -i $srcdir/946b7eea6d699731f72124d87b3176e0ced4d25a.patch
}
build() {
diff --git a/makefile-system-htslib.patch b/makefile-system-htslib.patch
index 91056165a424..7ae2b4c6f295 100644
--- a/makefile-system-htslib.patch
+++ b/makefile-system-htslib.patch
@@ -1,16 +1,18 @@
---- /tmp/bcftools-1.3/Makefile 2015-12-15 22:58:35.000000000 +0100
-+++ /tmp/makepkg/bcftools/src/bcftools-1.3/Makefile 2016-03-05 11:24:58.512091814 +0100
-@@ -28,18 +28,8 @@
+diff -aur /tmp/makepkg/bcftools/src/bcftools-1.3.1/Makefile /tmp/makepkg/bcftools/src/bcftools-1.3.1-patched/Makefile
+--- /tmp/makepkg/bcftools/src/bcftools-1.3.1/Makefile 2016-04-22 11:50:59.000000000 +0200
++++ /tmp/makepkg/bcftools/src/bcftools-1.3.1-patched/Makefile 2016-05-29 20:18:22.323268586 +0200
+@@ -28,18 +28,10 @@
all: $(PROG) $(TEST_PROG)
-# Adjust $(HTSDIR) to point to your top-level htslib directory
--HTSDIR = htslib-1.3
+-HTSDIR = htslib-1.3.1
-include $(HTSDIR)/htslib.mk
-HTSLIB = $(HTSDIR)/libhts.a
-BGZIP = $(HTSDIR)/bgzip
-TABIX = $(HTSDIR)/tabix
--
++HTSDIR = /usr/include
+
CC = gcc
-CPPFLAGS =
-CFLAGS = -g -Wall -Wc++-compat -O2
@@ -20,7 +22,7 @@
OBJS = main.o vcfindex.o tabix.o \
vcfstats.o vcfisec.o vcfmerge.o vcfquery.o vcffilter.o filter.o vcfsom.o \
-@@ -48,7 +38,7 @@
+@@ -48,7 +40,7 @@
vcfcnv.o HMM.o vcfplugin.o consensus.o ploidy.o version.o \
ccall.o em.o prob1.o kmin.o # the original samtools calling
@@ -29,7 +31,7 @@
GSL_LIBS =
# The polysomy command is not compiled by default because it brings dependency
-@@ -57,7 +47,7 @@
+@@ -57,7 +49,7 @@
ifdef USE_GPL
EXTRA_CPPFLAGS += -DUSE_GPL
OBJS += polysomy.o peakfit.o
@@ -38,7 +40,7 @@
endif
prefix = /usr/local
-@@ -101,11 +91,11 @@
+@@ -101,11 +93,11 @@
.c.o:
$(CC) $(CFLAGS) $(EXTRA_CPPFLAGS) $(CPPFLAGS) -c -o $@ $<
@@ -54,64 +56,7 @@
# Plugin rules
-@@ -136,20 +126,20 @@
- filter_h = filter.h $(htslib_vcf_h)
- ploidy_h = ploidy.h $(htslib_regidx_h)
- prob1_h = prob1.h $(htslib_vcf_h) $(call_h)
--roh_h = HMM.h $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kstring.h $(HTSDIR)/htslib/kseq.h $(bcftools_h)
-+roh_h = HMM.h $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h)
- cnv_h = HMM.h $(htslib_vcf_h) $(htslib_synced_bcf_reader_h)
-
- main.o: main.c $(htslib_hts_h) version.h $(bcftools_h)
--vcfannotate.o: vcfannotate.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h) vcmp.h $(filter_h)
--vcfplugin.o: vcfplugin.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h) vcmp.h $(filter_h)
--vcfcall.o: vcfcall.c $(htslib_vcf_h) $(HTSDIR)/htslib/kfunc.h $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/khash_str2int.h $(bcftools_h) $(call_h) $(prob1_h) $(ploidy_h)
--vcfconcat.o: vcfconcat.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h)
-+vcfannotate.o: vcfannotate.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) vcmp.h $(filter_h)
-+vcfplugin.o: vcfplugin.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) vcmp.h $(filter_h)
-+vcfcall.o: vcfcall.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) $(call_h) $(prob1_h) $(ploidy_h)
-+vcfconcat.o: vcfconcat.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h)
- vcfconvert.o: vcfconvert.c $(htslib_vcf_h) $(htslib_bgzf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h) $(convert_h) $(tsv2vcf_h)
- vcffilter.o: vcffilter.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h) rbuf.h
- vcfgtcheck.o: vcfgtcheck.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h)
- vcfindex.o: vcfindex.c $(htslib_vcf_h) $(htslib_tbx_h)
- vcfisec.o: vcfisec.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h)
--vcfmerge.o: vcfmerge.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) vcmp.h $(HTSDIR)/htslib/khash.h
-+vcfmerge.o: vcfmerge.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) vcmp.h
- vcfnorm.o: vcfnorm.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_faidx_h) $(bcftools_h) rbuf.h
- vcfquery.o: vcfquery.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h) $(convert_h)
- vcfroh.o: vcfroh.c $(roh_h)
-@@ -157,22 +147,22 @@
- vcfsom.o: vcfsom.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h)
- vcfstats.o: vcfstats.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(htslib_faidx_h) $(bcftools_h)
- vcfview.o: vcfview.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(filter_h)
--reheader.o: reheader.c $(htslib_vcf_h) $(htslib_bgzf_h) $(HTSDIR)/htslib/kseq.h $(bcftools_h)
-+reheader.o: reheader.c $(htslib_vcf_h) $(htslib_bgzf_h) $(bcftools_h)
- tabix.o: tabix.c $(htslib_bgzf_h) $(htslib_tbx_h)
--ccall.o: ccall.c $(HTSDIR)/htslib/kfunc.h $(call_h) kmin.h $(prob1_h)
-+ccall.o: ccall.c $(call_h) kmin.h $(prob1_h)
- convert.o: convert.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(htslib_vcfutils_h) $(bcftools_h) $(convert_h)
- tsv2vcf.o: tsv2vcf.c $(tsv2vcf_h)
- em.o: em.c $(htslib_vcf_h) kmin.h $(call_h)
--filter.o: filter.c $(HTSDIR)/htslib/khash_str2int.h $(filter_h) $(bcftools_h) $(htslib_hts_defs_h) $(htslib_vcfutils_h)
-+filter.o: filter.c $(filter_h) $(bcftools_h) $(htslib_hts_defs_h) $(htslib_vcfutils_h)
- gvcf.o: gvcf.c $(call_h)
- kmin.o: kmin.c kmin.h
--mcall.o: mcall.c $(HTSDIR)/htslib/kfunc.h $(call_h)
-+mcall.o: mcall.c $(call_h)
- prob1.o: prob1.c $(prob1_h)
- vcmp.o: vcmp.c $(htslib_hts_h) vcmp.h
--ploidy.o: ploidy.c $(htslib_regidx_h) $(HTSDIR)/htslib/khash_str2int.h $(HTSDIR)/htslib/kseq.h $(htslib_hts_h) $(bcftools_h) $(ploidy_h)
-+ploidy.o: ploidy.c $(htslib_regidx_h) $(htslib_hts_h) $(bcftools_h) $(ploidy_h)
- polysomy.o: polysomy.c $(htslib_vcf_h) $(htslib_synced_bcf_reader_h) $(bcftools_h) peakfit.h
--peakfit.o: peakfit.c peakfit.h $(htslib_hts_h) $(HTSDIR)/htslib/kstring.h
--consensus.o: consensus.c $(htslib_hts_h) $(HTSDIR)/htslib/kseq.h rbuf.h $(bcftools_h) $(HTSDIR)/htslib/regidx.h
-+peakfit.o: peakfit.c peakfit.h $(htslib_hts_h)
-+consensus.o: consensus.c $(htslib_hts_h) rbuf.h $(bcftools_h)
- version.o: version.h version.c
-
- test/test-rbuf.o: test/test-rbuf.c rbuf.h
-@@ -180,8 +170,8 @@
+@@ -180,8 +172,8 @@
test/test-rbuf: test/test-rbuf.o
$(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS)
@@ -122,3 +67,5 @@
doc/bcftools.1: doc/bcftools.txt
cd doc && a2x -adate="$(DOC_DATE)" -aversion=$(DOC_VERSION) --doctype manpage --format manpage bcftools.txt
+Only in /tmp/makepkg/bcftools/src/bcftools-1.3.1-patched: Makefile.orig
+Only in /tmp/makepkg/bcftools/src/bcftools-1.3.1-patched: Makefile.rej