summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2021-08-10 15:12:33 -0400
committerChris Severance2021-08-10 15:12:33 -0400
commitfa1921988504c98b6926c06b3aa3cf341cda4c65 (patch)
tree3f87724d412f54486b7196699e0a914e48fdaa19
parent35d93dde4d80e9f3c237946354094f2e41346a5c (diff)
downloadaur-fa1921988504c98b6926c06b3aa3cf341cda4c65.tar.gz
autu: Update to 6.10.0.1-1 tty_check_change
-rw-r--r--.SRCINFO7
-rw-r--r--0000-tty_unregister_driver-void.patch38
-rw-r--r--0001-kernel-5.13-dropped-tty_check_change.patch18
-rw-r--r--PKGBUILD18
4 files changed, 78 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2500943f76ee..d4fcba1c26ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,10 +26,15 @@ pkgbase = trueport
backup = etc/trueport/sslcfg.tp
source = https://www.perle.com/downloads/drivers/trueport/linux/trueport-6.10.0-1.tgz
source = tty_default_permissions.patch
+ source = 0000-tty_unregister_driver-void.patch
+ source = 0001-kernel-5.13-dropped-tty_check_change.patch
md5sums = 5a529676de30706133255ba4e8dae5b0
md5sums = 56444e2f404aa2e6a2c9e8e2bd919fcf
+ md5sums = fb798f306553cb253b30ff5af5ba2f40
+ md5sums = a103f2791c03733b1fd75493864fb464
sha256sums = c21340a7523593da3e229b79cfbcf9e656772b2039e972dbca3947d138d55ffa
sha256sums = 28863731fd99e447dc456312ef33e40f93623b56da0d345e45f40e238ca49639
+ sha256sums = 5f806246751d3a91c59bd97273221d1066006bafc7ed598c3d93f9b7bdae65a1
+ sha256sums = 88181bc7a0a5fa5a1320cbed20e02e1329b03b4c9800fc691990754b9a9aac18
pkgname = trueport
-
diff --git a/0000-tty_unregister_driver-void.patch b/0000-tty_unregister_driver-void.patch
new file mode 100644
index 000000000000..9db1f4af8884
--- /dev/null
+++ b/0000-tty_unregister_driver-void.patch
@@ -0,0 +1,38 @@
+diff -pNaru5 trueport-6.10.0.orig/ptyx/ptymod.c trueport-6.10.0/ptyx/ptymod.c
+--- trueport-6.10.0.orig/ptyx/ptymod.c 2020-05-28 07:56:32.000000000 -0400
++++ trueport-6.10.0/ptyx/ptymod.c 2021-08-10 15:06:08.809526111 -0400
+@@ -425,30 +425,21 @@ init_out:
+ return retval;
+ }
+
+ static void __exit ptyx_finish(void)
+ {
+- int e1, i;
++ int i;
+
+ ptyx_print(PTYX_DEBUG_MISC, ("ptyx_finish(): unregistering driver \n"));
+
+- if ( (e1 = tty_unregister_driver(ptyx_master_driver)) )
+- {
+- printk("ptyx_finish(): ptyx faied to unregister master TTY driver (%d) \n", e1);
+- }
++ tty_unregister_driver(ptyx_master_driver);
+ put_tty_driver(ptyx_master_driver);
+
+- if ( (e1 = tty_unregister_driver(ptyx_slave_driver)) )
+- {
+- printk("ptyx_finish(): ptyx faied to unregister slave TTY driver (%d) \n", e1);
+- }
++ tty_unregister_driver(ptyx_slave_driver);
+ put_tty_driver(ptyx_slave_driver);
+
+- if ( (e1 = tty_unregister_driver(ptyx_control_driver)) )
+- {
+- printk("ptyx_finish(): ptyx faied to unregister control status TTY driver (%d) \n", e1);
+- }
++ tty_unregister_driver(ptyx_control_driver);
+ put_tty_driver(ptyx_control_driver);
+
+ if (pty_state_table)
+ {
+ for (i = 0; i < max_installed_ports; i++)
diff --git a/0001-kernel-5.13-dropped-tty_check_change.patch b/0001-kernel-5.13-dropped-tty_check_change.patch
new file mode 100644
index 000000000000..2cf2f167ec72
--- /dev/null
+++ b/0001-kernel-5.13-dropped-tty_check_change.patch
@@ -0,0 +1,18 @@
+diff -pNaru5 trueport-6.10.0.orig/ptyx/ptys.c trueport-6.10.0/ptyx/ptys.c
+--- trueport-6.10.0.orig/ptyx/ptys.c 2020-05-28 07:56:32.000000000 -0400
++++ trueport-6.10.0/ptyx/ptys.c 2021-08-10 15:09:44.904120804 -0400
+@@ -487,10 +487,14 @@ static void ptyx_slave_start(struct tty_
+ // changing the state of a terminal when we are not a process
+ // in the forground. See tty_io.c
+ //
+ //*****************************************************************************
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,13,0)
++int tty_check_change(struct tty_struct *tty);
++#endif
++
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,39)) // Less than 2.6.39
+ static int ptyx_slave_ioctl(struct tty_struct *tty, struct file *file,
+ unsigned int cmd, unsigned long arg)
+ #else
+ static int ptyx_slave_ioctl(struct tty_struct *tty, unsigned int cmd, unsigned long arg)
diff --git a/PKGBUILD b/PKGBUILD
index 698fb7fe22cf..701004e8b6eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -121,11 +121,17 @@ source=(
# http://rglinuxtech.com/?p=1930
# https://forum.manjaro.org/t/error-with-rtl8812au/24066
#'trueport-patch-signal_pending-kernel-4-11.patch'
+ '0000-tty_unregister_driver-void.patch'
+ '0001-kernel-5.13-dropped-tty_check_change.patch'
)
md5sums=('5a529676de30706133255ba4e8dae5b0'
- '56444e2f404aa2e6a2c9e8e2bd919fcf')
+ '56444e2f404aa2e6a2c9e8e2bd919fcf'
+ 'fb798f306553cb253b30ff5af5ba2f40'
+ 'a103f2791c03733b1fd75493864fb464')
sha256sums=('c21340a7523593da3e229b79cfbcf9e656772b2039e972dbca3947d138d55ffa'
- '28863731fd99e447dc456312ef33e40f93623b56da0d345e45f40e238ca49639')
+ '28863731fd99e447dc456312ef33e40f93623b56da0d345e45f40e238ca49639'
+ '5f806246751d3a91c59bd97273221d1066006bafc7ed598c3d93f9b7bdae65a1'
+ '88181bc7a0a5fa5a1320cbed20e02e1329b03b4c9800fc691990754b9a9aac18')
if [ "${_opt_DKMS}" -ne 0 ]; then
depends+=('linux' 'dkms' 'linux-headers')
@@ -144,6 +150,14 @@ prepare() {
# diff -pNaru5 'trueport-6.8.0' 'trueport-6.8.5' > 'trueport-patch-6.8.0-6.8.5.patch'
#patch -Nup1 -i '../trueport-patch-6.8.0-6.8.5.patch'
+ #cd ..; cp -pr trueport-6.10.0{,.orig}; false
+ # diff -pNaru5 trueport-6.10.0{.orig,} > '0000-tty_unregister_driver-void.patch'
+ patch -Nup1 -i "${srcdir}/0000-tty_unregister_driver-void.patch"
+
+ #cd ..; cp -pr trueport-6.10.0{,.orig}; false
+ # diff -pNaru5 trueport-6.10.0{.orig,} > '0001-kernel-5.13-dropped-tty_check_change.patch'
+ patch -Nup1 -i "${srcdir}/0001-kernel-5.13-dropped-tty_check_change.patch"
+
# insert parameters and make install script non interactive.
set +u; msg2 'Checking SSL with rpm_build'; set -u
sed -e 's:^\(DONE\)=.*$:'"\1='done';SSL='${_opt_SSL}':g" \