summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Dubovik2024-02-18 13:58:13 +0100
committerAndrei Dubovik2024-02-18 13:58:13 +0100
commitfa32499e5f059bcf55b48b9961e758ab8611c883 (patch)
tree10c6658f7f0b37c400f630d4b85f78a253fdd260
parent40e41932327434201a6c3302114ac97b33b82d68 (diff)
downloadaur-fa32499e5f059bcf55b48b9961e758ab8611c883.tar.gz
Bumped the version to 3.9.1; updated the patch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--keyfile.patch18
3 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index debb1a9d891a..54b99f72963b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = protonmail-bridge-nokeychain
pkgdesc = An IMAP/SMTP bridge to a ProtonMail account (patched, stores secrets in a file)
- pkgver = 3.8.2
+ pkgver = 3.9.1
pkgrel = 1
url = https://protonmail.com/bridge/
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = protonmail-bridge-nokeychain
provides = protonmail-bridge
conflicts = protonmail-bridge
options = !strip
- source = https://github.com/ProtonMail/proton-bridge/archive/refs/tags/v3.8.2.tar.gz
+ source = https://github.com/ProtonMail/proton-bridge/archive/refs/tags/v3.9.1.tar.gz
source = keyfile.patch
source = protonmail-bridge.service
- sha256sums = 3d844fa74c06767283a73305737e82b9ec7c59cc35d08fcb8a5bd68a128735e2
- sha256sums = 075bf87cec3f12d76ab97ccdfc22d5e3f9dd001eff23a843d4a2228b016fb20a
+ sha256sums = b802d6d9cd96c7ba78ed3dc6a07b04ff9a19b37f6611562aab5745658b5e0a49
+ sha256sums = 7b9a81c7cc519307fb677c0ee3b7948fe75f860c38de66de4d82c01150adc836
sha256sums = 5ffaaa5acc030ebed82b3b13f1ddc2791b50851fb93964a5d6a20a11000c18c2
pkgname = protonmail-bridge-nokeychain
diff --git a/PKGBUILD b/PKGBUILD
index adafd38c1f51..7f0818fe32ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=protonmail-bridge-nokeychain
provides=("protonmail-bridge")
conflicts=("protonmail-bridge")
-pkgver=3.8.2
+pkgver=3.9.1
pkgrel=1
pkgdesc="An IMAP/SMTP bridge to a ProtonMail account (patched, stores secrets in a file)"
arch=("x86_64")
@@ -17,8 +17,8 @@ source=(
"protonmail-bridge.service"
)
sha256sums=(
- "3d844fa74c06767283a73305737e82b9ec7c59cc35d08fcb8a5bd68a128735e2"
- "075bf87cec3f12d76ab97ccdfc22d5e3f9dd001eff23a843d4a2228b016fb20a"
+ "b802d6d9cd96c7ba78ed3dc6a07b04ff9a19b37f6611562aab5745658b5e0a49"
+ "7b9a81c7cc519307fb677c0ee3b7948fe75f860c38de66de4d82c01150adc836"
"5ffaaa5acc030ebed82b3b13f1ddc2791b50851fb93964a5d6a20a11000c18c2"
)
diff --git a/keyfile.patch b/keyfile.patch
index e24f21994a76..a7f611173ded 100644
--- a/keyfile.patch
+++ b/keyfile.patch
@@ -1,5 +1,5 @@
diff --git a/internal/app/migration.go b/internal/app/migration.go
-index b2ed8610..5b95887f 100644
+index 0f7b9f6b..d8e8b823 100644
--- a/internal/app/migration.go
+++ b/internal/app/migration.go
@@ -43,8 +43,6 @@ import (
@@ -30,10 +30,10 @@ index b2ed8610..5b95887f 100644
return fmt.Errorf("failed to read old prefs file: %w", err)
}
diff --git a/pkg/keychain/helper_linux.go b/pkg/keychain/helper_linux.go
-index 1ab288e9..b4c44b27 100644
+index ce531faa..0a89c06b 100644
--- a/pkg/keychain/helper_linux.go
+++ b/pkg/keychain/helper_linux.go
-@@ -18,60 +18,41 @@
+@@ -18,63 +18,42 @@
package keychain
import (
@@ -60,25 +60,29 @@ index 1ab288e9..b4c44b27 100644
- if isUsable(newDBusHelper("")) {
- helpers[SecretServiceDBus] = newDBusHelper
+- logrus.WithField("keychain", "SecretServiceDBus").Info("Keychain is usable.")
- } else {
-- logrus.WithField("keychain", "SecretServiceDBus").Warn("Keychain is not available.")
+- logrus.WithField("keychain", "SecretServiceDBus").Debug("Keychain is not available.")
- }
-
- if _, err := execabs.LookPath("gnome-keyring"); err == nil && isUsable(newSecretServiceHelper("")) {
- helpers[SecretService] = newSecretServiceHelper
+- logrus.WithField("keychain", "SecretService").Info("Keychain is usable.")
- } else {
-- logrus.WithField("keychain", "SecretService").Warn("Keychain is not available.")
+- logrus.WithField("keychain", "SecretService").Debug("Keychain is not available.")
- }
-
- if _, err := execabs.LookPath("pass"); err == nil && isUsable(newPassHelper("")) {
- helpers[Pass] = newPassHelper
+- logrus.WithField("keychain", "Pass").Info("Keychain is usable.")
+ // Use keyFile as the only secrets handler
+ if isUsable(newKeyFileHelper("")) {
+ helpers["key-file"] = newKeyFileHelper
+ defaultHelper = "key-file"
++ logrus.WithField("keychain", "KeyFile").Info("Keychain is usable.")
} else {
-- logrus.WithField("keychain", "Pass").Warn("Keychain is not available.")
-+ logrus.WithField("keychain", "KeyFile").Warn("Keychain is not available.")
+- logrus.WithField("keychain", "Pass").Debug("Keychain is not available.")
++ logrus.WithField("keychain", "KeyFile").Debug("Keychain is not available.")
}
- defaultHelper := SecretServiceDBus