summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMort Yao2015-06-09 14:37:52 +0800
committerMort Yao2015-06-09 14:37:52 +0800
commitfa33fa134c1cfca3f8b278e8a240538869bd0527 (patch)
treeaea9b002be40e7e7aa3b59344b9f25ffadbe7d88
downloadaur-fa33fa134c1cfca3f8b278e8a240538869bd0527.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--emacs-processing-mode-git.install11
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc9a36901477
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = emacs-processing-mode-git
+ pkgdesc = Major mode for Processing 2.0.
+ pkgver = 20150609
+ pkgrel = 1
+ url = https://github.com/ptrv/processing2-emacs
+ install = emacs-processing-mode-git.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ provides = emacs-processing-mode
+ replaces = emacs-processing-mode
+ source =
+ md5sums =
+
+pkgname = emacs-processing-mode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7c3c1d8c988
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Mort Yao <soi@mort.ninja>
+
+pkgname=emacs-processing-mode-git
+pkgver=20150609
+pkgrel=1
+pkgdesc="Major mode for Processing 2.0."
+arch=('any')
+url="https://github.com/ptrv/processing2-emacs"
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-processing-mode')
+replaces=('emacs-processing-mode')
+install=$pkgname.install
+source=()
+md5sums=()
+
+_gitroot="git://github.com/ptrv/processing2-emacs.git"
+_gitname="processing2-emacs"
+
+build() {
+ cd $startdir/src
+ msg "Connecting to GIT server..."
+
+ if [ -d $startdir/src/$_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+}
+
+package() {
+ cd $startdir/src/$_gitname
+
+ mkdir -p $pkgdir/usr/share/emacs/site-lisp/processing-mode
+ emacs -batch -f batch-byte-compile processing-mode.el
+ install -Dm644 processing-mode.el processing-mode.elc $pkgdir/usr/share/emacs/site-lisp/processing-mode
+}
diff --git a/emacs-processing-mode-git.install b/emacs-processing-mode-git.install
new file mode 100644
index 000000000000..121e4f4277e6
--- /dev/null
+++ b/emacs-processing-mode-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ cat <<EOF
+==> Put this in your \$HOME/.emacs file:
+==> (autoload 'processing-mode "processing-mode" "Processing mode" t)
+==> (add-to-list 'auto-mode-alist '("\\.pde$" . processing-mode))
+EOF
+}
+
+op=$1
+shift
+$op $*