summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Venries2016-11-04 12:59:13 +0100
committerThomas Venries2016-11-04 15:13:59 +0100
commitfa34861ba548424e340ce21bac10ff9ae398e222 (patch)
tree16c6c00feaa0792f1a9b15c9e552fc63cd8c2337
downloadaur-fa34861ba548424e340ce21bac10ff9ae398e222.tar.gz
Initial Release 1.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0040c4085147
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pearlfan
+ pkgdesc = Tool to control Pearl USB LED fan.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/Ventto/pearlfan
+ arch = x86_64
+ license = GPL3
+ makedepends = help2man netpbm
+ source = https://github.com/Ventto/pearlfan/archive/v1.0.tar.gz
+ sha256sums = c3861722d533db3a99859fb4a2a620a995be98479ea71d41f3565b6c4a85d82a
+
+pkgname = pearlfan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..826b4da0b5c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Thomas "Ventto" Venriès <thomas.venries@gmail.com>
+
+pkgname=pearlfan
+pkgver=1.0
+pkgrel=1
+pkgdesc='Tool to control Pearl USB LED fan.'
+arch=('x86_64')
+url="https://github.com/Ventto/${pkgname}"
+license=('GPL3')
+makedepends=('help2man netpbm')
+source=("https://github.com/Ventto/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('c3861722d533db3a99859fb4a2a620a995be98479ea71d41f3565b6c4a85d82a')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make -f Makefile.libusb
+ help2man -N -n "${pkgdesc}" -h -h -v -v ${pkgname} | gzip - > ${pkgname}.1.gz
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 ${pkgname}.1.gz ${pkgdir}/usr/share/man/man1/${pkgname}.1.gz
+ cp -r tests/images ${pkgdir}/usr/share/${pkgname}/
+ install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ chmod 4755 ${pkgdir}/usr/bin/${pkgname}
+}