summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Lansdowne2013-12-12 20:07:37 +0000
committerJoseph Lansdowne2013-12-12 20:07:37 +0000
commitfa4c4b7211b0250d16cfdd1d373402894b5e39e2 (patch)
tree3d6669057b168189332e4d38cd4e555c639f1f33
downloadaur-fa4c4b7211b0250d16cfdd1d373402894b5e39e2.tar.gz
add escapegoat
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD57
-rwxr-xr-xescapegoat4
-rw-r--r--escapegoat.desktop8
-rw-r--r--escapegoat.pngbin0 -> 661 bytes
5 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d055dbd86fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = escapegoat
+ pkgdesc = Escape Goat is a puzzle platformer about a goat
+ pkgver = 20131018
+ pkgrel = 1
+ url = http://www.magicaltimebean.com/escape-goat/
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ makedepends = unzip
+ depends = sdl2
+ depends = openal
+ source = escapegoat
+ source = escapegoat.desktop
+ source = escapegoat.png
+ md5sums = d5c6ac99897ac33e23593849c59931d5
+ md5sums = db54523ac2b3c29038696d62b9a355f9
+ md5sums = 0f5dc590a0f437ebccc770ca9f2a16c4
+
+pkgname = escapegoat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..419683b6773a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Joseph Lansdowne <J49137@gmail.com>
+pkgname=escapegoat
+pkgver=20131018
+pkgrel=1
+pkgdesc="Escape Goat is a puzzle platformer about a goat"
+arch=(i686 x86_64)
+url="http://www.magicaltimebean.com/escape-goat/"
+license=(custom:commercial)
+makedepends=(unzip)
+depends=(sdl2 openal)
+source=("$pkgname" "$pkgname.desktop" "$pkgname.png")
+md5sums=('d5c6ac99897ac33e23593849c59931d5'
+ 'db54523ac2b3c29038696d62b9a355f9'
+ '0f5dc590a0f437ebccc770ca9f2a16c4')
+PKGEXT=.pkg.tar
+
+_archive="$pkgname-10182013-bin"
+_archive_md5='8b78d08df9aa3f403ea621c5d084d4ee'
+
+build () {
+ echo "$_archive_md5 $startdir/$_archive" | md5sum -c || {
+ echo "archive not found or wrong checksum (Escape Goat is a" \
+ "commercial game)" 1>&2
+ exit 1
+ }
+
+ unzip -qqod "$srcdir/$pkgname-archive" "$startdir/$_archive" || {
+ # unzip gives exit status 1 if warnings occurred
+ if [ "$?" -ne 1 ]; then
+ echo "extracting archive failed" 1>&2
+ exit 1
+ fi
+ }
+}
+
+package () {
+ install -d "$pkgdir/opt/"
+ cp -Rl "$srcdir/$pkgname-archive/data/" "$pkgdir/opt/$pkgname"
+
+ if [ "$CARCH" = x86_64 ]; then
+ libdir=lib64
+ otherlibdir=lib
+ else
+ libdir=lib
+ otherlibdir=lib64
+ fi
+
+ # these are in deps
+ rm -f "$pkgdir/opt/$pkgname/$libdir"/{libopenal.so.1,libSDL2-2.0.so.0}
+ rm -rf "$pkgdir/opt/$pkgname/$otherlibdir"
+
+ install -Dm755 "$srcdir/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/$pkgname.png" \
+ "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}
diff --git a/escapegoat b/escapegoat
new file mode 100755
index 000000000000..7516ec356141
--- /dev/null
+++ b/escapegoat
@@ -0,0 +1,4 @@
+#! /bin/sh
+
+cd /opt/escapegoat
+exec ./EscapeGoat
diff --git a/escapegoat.desktop b/escapegoat.desktop
new file mode 100644
index 000000000000..3340777a1564
--- /dev/null
+++ b/escapegoat.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Escape Goat
+Comment=A goat, imprisoned for witchcraft, must escape the treacherous Prison of Agnus
+Icon=escapegoat
+Exec=/usr/bin/escapegoat
+Categories=Game;
diff --git a/escapegoat.png b/escapegoat.png
new file mode 100644
index 000000000000..c1f3273b8170
--- /dev/null
+++ b/escapegoat.png
Binary files differ