summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 21:04:21 +0100
committersL1pKn072019-03-02 21:04:21 +0100
commitfa5a9f771eb8102dff29647a73c24bf6b79537ca (patch)
tree9278fb751d67c9a50f78485800c1b29f2a78722d
downloadaur-fa5a9f771eb8102dff29647a73c24bf6b79537ca.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c82d286c9797
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Mar 2 20:04:21 UTC 2019
+pkgbase = vapoursynth-plugin-fftspectrum-git
+ pkgdesc = Plugin for Vapoursynth: fftspectrum (GIT version)
+ pkgver = r1.1.g0fe5160
+ pkgrel = 1
+ url = https://github.com/Beatrice-Raws/FFTSpectrum
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ depends = fftw
+ provides = vapoursynth-plugin-fftspectrum
+ conflicts = vapoursynth-plugin-fftspectrum
+ source = fftspectrum::git+https://github.com/Beatrice-Raws/FFTSpectrum.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-fftspectrum-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..569778c3e169
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=fftspectrum
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r1.1.g0fe5160
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/Beatrice-Raws/FFTSpectrum'
+license=('GPL')
+depends=('vapoursynth'
+ 'fftw'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Beatrice-Raws/FFTSpectrum.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+
+ sed -e 's|"vapoursynth/VapourSynth.h"|<VapourSynth.h>|g' \
+ -e 's|"vapoursynth/VSHelper.h"|<VSHelper.h>|g' \
+ -e 's|"fftw3.h"|<fftw3.h>|g' \
+ -i FFTSpectrum.c
+
+ echo "all:
+ gcc -c -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o FFTSpectrum.o FFTSpectrum.c
+ gcc -shared $(pkg-config --libs fftw3f) -fPIC ${LDFLAGS} -o lib${_plug}.so FFTSpectrum.o" > Makefile
+}
+
+build() {
+ make -C "${_plug}"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}