summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Redaelli2015-09-09 00:22:05 +0200
committerTimothy Redaelli2015-09-09 00:28:37 +0200
commitfa688b27c16b3be21c5be2eeb367840b02b5421e (patch)
tree4d24a7d21a2970a2501fed5609531379d9421956
downloadaur-fa688b27c16b3be21c5be2eeb367840b02b5421e.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
-rw-r--r--dkms.conf11
-rw-r--r--remove-lru_cache_add_anon.patch11
-rw-r--r--ufsd-module-dkms.install37
5 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8240cbe38c28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ufsd-module-dkms
+ pkgdesc = Paragon NTFS & HFS for Linux driver. - ACLs removed. DKMS version
+ pkgver = 9.0
+ pkgrel = 1
+ url = http://paragon-software.com/
+ install = ufsd-module-dkms.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = linux-lts-headers
+ depends = dkms
+ depends = linux-lts<3.16
+ source = dkms.conf
+ source = remove-lru_cache_add_anon.patch
+ md5sums = 838702d38c5d51f14f52b2b5312e0f33
+ md5sums = 22e227efcee141c8c41798b39dbb62f2
+ md5sums = f874a41209d93998df1d44f60e96a7bd
+
+pkgname = ufsd-module-dkms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb8af20ab13b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Kowalczyk Patryk <patryk AT kowalczyk DOT ws>
+# Contributor: <John freehaha at gmail dot com> - patch paragon-ufsd-3.10_v01.patch
+# Contributor: Pradeep Murthy <pradeepmur (at) gmail> (dkms wrapper)
+
+pkgname=ufsd-module-dkms
+_pkgname=ufsd-module
+pkgver=9.0
+_srcdir=Paragon-147-FRE_NTFS_Linux_${pkgver}_Express
+pkgrel=1
+pkgdesc='Paragon NTFS & HFS for Linux driver. - ACLs removed. DKMS version'
+arch=('i686' 'x86_64')
+url='http://paragon-software.com/'
+license=('custom')
+depends=('dkms' 'linux-lts<3.16')
+makedepends=('linux-lts-headers')
+install=ufsd-module-dkms.install
+
+# Download the file from <http://www.paragon-software.com/home/ntfs-linux-per/download.html>
+source=("Paragon-147-FRE_NTFS_Linux_${pkgver}_Express.tar.gz"
+ "dkms.conf"
+ "remove-lru_cache_add_anon.patch"
+)
+
+md5sums=('838702d38c5d51f14f52b2b5312e0f33'
+ '22e227efcee141c8c41798b39dbb62f2'
+ 'f874a41209d93998df1d44f60e96a7bd')
+
+prepare() {
+ cd "$_srcdir"
+ patch -Np1 -i "$srcdir"/remove-lru_cache_add_anon.patch
+}
+
+package() {
+ install -dm755 ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+ sed "s/%pkgver%/$pkgver/" dkms.conf > ${pkgdir}/usr/src/${_pkgname}-${pkgver}/dkms.conf
+ cp -RL ${_srcdir}/* ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+}
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..4ba720630c41
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,11 @@
+PACKAGE_NAME="ufsd-module"
+PACKAGE_VERSION="%pkgver%"
+PRE_BUILD="./configure --prefix=/usr --sbindir=/usr/bin"
+BUILT_MODULE_NAME[0]="ufsd"
+BUILT_MODULE_NAME[1]="jnl"
+DEST_MODULE_NAME[0]="ufsd"
+DEST_MODULE_NAME[1]="jnl"
+DEST_MODULE_LOCATION[0]="/extramodules"
+DEST_MODULE_LOCATION[1]="/extramodules"
+AUTOINSTALL="yes"
+REMAKE_INITRD="yes"
diff --git a/remove-lru_cache_add_anon.patch b/remove-lru_cache_add_anon.patch
new file mode 100644
index 000000000000..afd0149be43f
--- /dev/null
+++ b/remove-lru_cache_add_anon.patch
@@ -0,0 +1,11 @@
+--- Paragon-147-FRE_NTFS_Linux_9.0_Express/ifslinux/ufsdvfs.c.orig 2015-09-09 00:05:01.695085717 +0200
++++ Paragon-147-FRE_NTFS_Linux_9.0_Express/ifslinux/ufsdvfs.c 2015-09-09 00:05:21.355151784 +0200
+@@ -8235,7 +8235,7 @@
+ err = err2;
+ }
+
+- PageSwapBacked( page )? lru_cache_add_anon( page ) : lru_cache_add_file( page );
++ lru_cache_add_file( page );
+ }
+
+ page_cache_release( page );
diff --git a/ufsd-module-dkms.install b/ufsd-module-dkms.install
new file mode 100644
index 000000000000..59ac36496d94
--- /dev/null
+++ b/ufsd-module-dkms.install
@@ -0,0 +1,37 @@
+post_install() {
+ local pkgver=${1%%-*}
+ /usr/src/ufsd-module-$pkgver/configure --prefix=/usr --sbindir=/usr/bin
+
+ echo ">>> DKMS: Module add, build, and install"
+
+ dkms add -m ufsd-module -v $pkgver
+ dkms build -m ufsd-module -v $pkgver
+ dkms install -m ufsd-module -v $pkgver
+
+ depmod -a
+
+ cat <<EOF
+==> For more information on this driver, see:
+==> https://aur.archlinux.org/packages/ufsd-module
+EOF
+}
+
+pre_upgrade() {
+ pre_remove $1
+}
+
+pre_remove() {
+ local pkgver=${1%%-*}
+ echo ">>> DKMS: Module uninstall"
+
+ line=`dkms status -m ufsd-module`
+ if echo "$line" | grep -E 'added|built|installed'; then
+ dkms remove ufsd-module/$pkgver --all
+ fi
+
+ depmod -a
+}
+
+post_upgrade() {
+ post_install $1
+}