summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitlab CI Runner2020-07-02 08:31:19 +0000
committerGitlab CI Runner2020-07-02 08:31:19 +0000
commitfa75845ba6dcc2c458820e7ce1b75378d8272ad9 (patch)
tree7b81847315949b2a3fe22fba69140ebf1ac4841f
parent9468b2a25e04640a0923611b92e7f2da155c2926 (diff)
downloadaur-fa75845ba6dcc2c458820e7ce1b75378d8272ad9.tar.gz
Updated package to commit
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--rapidcheck.changelog23
3 files changed, 28 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3006c135141..dfd06fd75300 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rapidcheck
pkgdesc = QuickCheck clone for C++ with the goal of being simple to use with as little boilerplate as possible.
- pkgver = r1002.258d907
+ pkgver = r1006.7bc7d30
pkgrel = 1
url = https://github.com/emil-e/rapidcheck
changelog = rapidcheck.changelog
@@ -12,8 +12,8 @@ pkgbase = rapidcheck
arch = aarch64
license = BSD
makedepends = cmake
- provides = rapidcheck=r1002.258d907
- source = rapidcheck::git+https://github.com/emil-e/rapidcheck.git#commit=258d907da00a0855f92c963d8f76eef115531716
+ provides = rapidcheck=r1006.7bc7d30
+ source = rapidcheck::git+https://github.com/emil-e/rapidcheck.git#commit=7bc7d302191a4f3d0bf005692677126136e02f60
md5sums = SKIP
pkgname = rapidcheck
diff --git a/PKGBUILD b/PKGBUILD
index 35e134409e1b..4c08c4cbfad3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bart Verhagen <bart at verhagenconsultancy dot be>
pkgname=('rapidcheck')
pkgbase='rapidcheck'
-pkgver=r1002.258d907
+pkgver=r1006.7bc7d30
pkgrel=1
epoch=
pkgdesc="QuickCheck clone for C++ with the goal of being simple to use with as little boilerplate as possible."
@@ -13,14 +13,14 @@ depends=()
makedepends=(cmake)
checkdepends=()
optdepends=()
-provides=('rapidcheck=r1002.258d907')
+provides=('rapidcheck=r1006.7bc7d30')
conflicts=()
replaces=()
backup=()
options=()
install=
changelog=rapidcheck.changelog
-source=("rapidcheck::git+$url.git#commit=258d907da00a0855f92c963d8f76eef115531716")
+source=("rapidcheck::git+$url.git#commit=7bc7d302191a4f3d0bf005692677126136e02f60")
noextract=()
validpgpkeys=()
diff --git a/rapidcheck.changelog b/rapidcheck.changelog
index 3ea4047ee9a1..d243edc47447 100644
--- a/rapidcheck.changelog
+++ b/rapidcheck.changelog
@@ -2,7 +2,7 @@ Changelog
=========
-r1002.258d907
+r1006.7bc7d30
------------
Fix
@@ -17,6 +17,27 @@ Fix
Other
~~~~~
+- Merge pull request #251 from dartdart26/variadic_macro_last_arg.
+ [emil-e]
+
+ Add argument for "..." in variadic assert macros
+- Add argument for "..." in variadic assert macros. [Petar Ivanov]
+
+ As per GCC's error message: ISO C++11 requires at least one argument for
+ the "..." in a variadic macro. This can be noticed if compiling with
+ -pedantic, producing a warning. If -Werror is added, it becomes an
+ error. This PR adds a dummy last argument in all cases using the
+ RC_INTERNAL_CONDITIONAL_RESULT macro without one.
+- Merge pull request #253 from gebart/fix-Wimplicit-int-float-
+ conversion. [emil-e]
+- Numeric: Fix Wimplicit-int-float-conversion with clang-10. [Joakim
+ Nohlgård]
+
+ Avoid warning by using explicit casting to double
+
+ ../include/rapidcheck/gen/Numeric.hpp:46:43: warning: implicit conversion from 'std::__1::numeric_limits<unsigned long long>::type' (aka 'unsigned long long') to 'double' changes value from 18446744073709551615 to 18446744073709551616 [-Wimplicit-int-float-conversion]
+ (stream.next<uint64_t>() * scale) / std::numeric_limits<uint64_t>::max();
+ ~ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
- Merge pull request #233 from Cypher1/master. [emil-e]
Fix type error detected by GCC-9.1.0