summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-12-15 10:35:40 +0100
committerDaniel Peukert2023-12-15 10:35:40 +0100
commitfa79bf37b04799b11998edb41fe322bb18f7b676 (patch)
treedcab551f64b4ca3a8458fe36a26263c59e70db7b
parent9f4797664d96d1139034fff17da03f89bdcd3db7 (diff)
downloadaur-fa79bf37b04799b11998edb41fe322bb18f7b676.tar.gz
Update salvador to 2.3.0
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD6
3 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3f5a005a9e0..e0c472ecb691 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = salvador
pkgdesc = A bash script that will help you maintain your AUR packages
- pkgver = 2.2.2
+ pkgver = 2.3.0
pkgrel = 1
url = https://gitlab.com/dpeukert/salvador
arch = any
@@ -11,7 +11,7 @@ pkgbase = salvador
optdepends = curl: nvchecker functionality
optdepends = jq: nvchecker functionality
optdepends = nvchecker: nvchecker functionality
- source = salvador-2.2.2-1.tar.gz::https://gitlab.com/dpeukert/salvador/-/archive/2.2.2/salvador-2.2.2.tar.gz
- sha512sums = 5c1f810b5458308e2f21c9ead7376ed1d8938e2ada76b4c2e5d5c51938a04925689f7a3141934a83253c6f27998900e84150c30b8f9483c8051e538bd16fac5f
+ source = salvador-2.3.0.tar.gz::https://gitlab.com/dpeukert/salvador/-/archive/2.3.0/salvador-2.3.0.tar.gz
+ sha512sums = 55dabfb144b6eb3c0cd25bcfcd94082630b4a2125f25c1f9eff2da18c65bbc8e0935b86e516daa775b09eb839dda9f69d9f1a9d25d5d6b28ac370170dff55130
pkgname = salvador
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..004b0a3a8706 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 3bbc7fb41711..86a1feef7e80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
pkgname='salvador'
-pkgver='2.2.2'
+pkgver='2.3.0'
pkgrel='1'
pkgdesc='A bash script that will help you maintain your AUR packages'
arch=('any')
@@ -12,8 +12,8 @@ optdepends=(
'jq: nvchecker functionality'
'nvchecker: nvchecker functionality'
)
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha512sums=('5c1f810b5458308e2f21c9ead7376ed1d8938e2ada76b4c2e5d5c51938a04925689f7a3141934a83253c6f27998900e84150c30b8f9483c8051e538bd16fac5f')
+source=("$pkgname-$pkgver.tar.gz::$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('55dabfb144b6eb3c0cd25bcfcd94082630b4a2125f25c1f9eff2da18c65bbc8e0935b86e516daa775b09eb839dda9f69d9f1a9d25d5d6b28ac370170dff55130')
package() {
cd "$srcdir/$pkgname-$pkgver/"