summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKopfKrieg2018-06-24 14:55:42 +0200
committerKopfKrieg2018-06-24 14:55:42 +0200
commitfa90b17ee38daf1e0afa1489a1273878b8e6ebec (patch)
treee4a837732940496e3893e846c8c3919668162902
parentbca0917b6bfbc0b3343fa5c64ee9ca2f37f94508 (diff)
downloadaur-fa90b17ee38daf1e0afa1489a1273878b8e6ebec.tar.gz
Updated to version 2.3.1-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84a44d67da88..34dbb001226d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-gnupg-isis
pkgdesc = A modified version of python-gnupg, including security patches, extensive documentation, and extra features. The gnupg module allows Python programs to make use of the functionality provided by the GNU Privacy Guard.
- pkgver = 2.3.0
+ pkgver = 2.3.1
pkgrel = 1
url = https://github.com/isislovecruft/python-gnupg
arch = any
@@ -10,9 +10,8 @@ pkgbase = python-gnupg-isis
depends = python-psutil
provides = python-gnupg
conflicts = python-gnupg
- replaces = python-gnupg-ng
- source = git://github.com/isislovecruft/python-gnupg.git
- md5sums = SKIP
+ source = https://github.com/isislovecruft/python-gnupg/archive/2.3.1.tar.gz
+ md5sums = b08128652940f0dc1fd1b94d2e4efea2
pkgname = python-gnupg-isis
diff --git a/PKGBUILD b/PKGBUILD
index 8d9a5b82a650..600125bd4f6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: KopfKrieg <archlinux [at] absolem [dot] cc>
pkgname=python-gnupg-isis
-_gitname=python-gnupg
-pkgver=2.3.0
+name=python-gnupg
+pkgver=2.3.1
pkgrel=1
pkgdesc='A modified version of python-gnupg, including security patches, extensive documentation, and extra features. The gnupg module allows Python programs to make use of the functionality provided by the GNU Privacy Guard.'
url='https://github.com/isislovecruft/python-gnupg'
@@ -11,18 +11,15 @@ arch=('any')
depends=('python' 'gnupg' 'python-psutil')
conflicts=('python-gnupg')
provides=('python-gnupg')
-replaces=('python-gnupg-ng')
-source=('git://github.com/isislovecruft/python-gnupg.git')
-md5sums=('SKIP')
+source=("https://github.com/isislovecruft/python-gnupg/archive/$pkgver.tar.gz")
+md5sums=('b08128652940f0dc1fd1b94d2e4efea2')
build() {
- cd $_gitname
- git checkout $pkgver
+ cd $name-$pkgver
python setup.py build
}
package() {
- cd $_gitname
- git checkout $pkgver
+ cd $name-$pkgver
python setup.py install --root=${pkgdir} --optimize=1
}