summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-04-27 13:15:24 -0500
committerCarlos Aznarán Laos2023-04-27 13:15:24 -0500
commitfaa25f138bbed884634140d40ea225c81f2cc19c (patch)
tree8b2859d25dc6567c07ae6a7dd31946a9ace57c4c
parent216a78f4868092b1a6d7f4b968ef0ac3cec82a17 (diff)
downloadaur-faa25f138bbed884634140d40ea225c81f2cc19c.tar.gz
Bump version to 4.1.0
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD81
3 files changed, 45 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f91c0d878b4..ce17bd5648b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,26 @@
pkgbase = mlpack
pkgdesc = A fast, flexible, scalable C++ machine learning library
- pkgver = 3.4.2
+ pkgver = 4.1.0
pkgrel = 1
- url = https://mlpack.org/
+ url = https://mlpack.org
arch = x86_64
- license = BSD
- makedepends = cmake>=3.3.2
+ license = custom:BSD-3-clause
+ makedepends = cmake
makedepends = txt2man
makedepends = python-setuptools
- depends = armadillo>=8.400.0
- depends = boost>=1.58
+ depends = armadillo
+ depends = cereal
+ depends = boost
depends = lapack
- depends = ensmallen>=2.10.0
- depends = cython>=0.24
+ depends = ensmallen
+ depends = cython
depends = python-numpy
- depends = python-pandas>=0.15.0
+ depends = python-pandas
optdepends = openmp: parallel computation support
- optdepends = julia>=2:1.3.0: julia bindings support
- optdepends = go>=2:1.12.9-1: go bindings support
- source = https://www.mlpack.org/files/mlpack-3.4.2.tar.gz
- sha256sums = 9e5c4af5c276c86a0dcc553289f6fe7b1b340d61c1e59844b53da0debedbb171
+ optdepends = julia: julia bindings support
+ optdepends = go: go bindings support
+ options = !emptydirs
+ source = https://mlpack.org/files/mlpack-4.1.0.tar.gz
+ sha512sums = 0cab346f81b04a298f09ba28cec679c275af80c3941f31977ba5d0cfe11eed5850190ce46e71cf003996391618ad4eac2e0a54e260d264b8f8f9a02f53ec7cc7
pkgname = mlpack
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 5d9b869df5e1..1cae75f8f79c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,62 +1,39 @@
-# Maintainer: Roberto Hueso < roberto at robertohueso dot org >
-# Former Maintainer: jerry73204 <jerry73204@gmail.com>
-# Former Maintainer: Govind Gopakumar < govind.93 at gmail dot com>
-# Former Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Roberto Hueso <roberto at robertohueso dot org>
+# Contributor: jerry73204 <jerry73204@gmail.com>
+# Contributor: Govind Gopakumar <govind.93 at gmail dot com>
+# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
pkgname=mlpack
-pkgver=3.4.2
+pkgver=4.1.0
pkgrel=1
-pkgdesc='A fast, flexible, scalable C++ machine learning library'
-arch=('x86_64')
-url="https://mlpack.org/"
-license=('BSD')
-depends=(
- 'armadillo>=8.400.0'
- 'boost>=1.58'
- 'lapack'
- 'ensmallen>=2.10.0'
- 'cython>=0.24'
- 'python-numpy'
- 'python-pandas>=0.15.0'
-)
-
-optdepends=(
- 'openmp: parallel computation support'
- 'julia>=2:1.3.0: julia bindings support'
- 'go>=2:1.12.9-1: go bindings support'
-)
-
-makedepends=(
- 'cmake>=3.3.2'
- 'txt2man'
- 'python-setuptools'
-)
-source=("https://www.mlpack.org/files/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('9e5c4af5c276c86a0dcc553289f6fe7b1b340d61c1e59844b53da0debedbb171')
+pkgdesc="A fast, flexible, scalable C++ machine learning library"
+arch=(x86_64)
+url="https://${pkgname}.org"
+license=('custom:BSD-3-clause')
+depends=(armadillo cereal boost lapack ensmallen cython python-numpy python-pandas)
+makedepends=(cmake txt2man python-setuptools)
+optdepends=('openmp: parallel computation support'
+ 'julia: julia bindings support'
+ 'go: go bindings support')
+source=(${url}/files/${pkgname}-${pkgver}.tar.gz)
+sha512sums=('0cab346f81b04a298f09ba28cec679c275af80c3941f31977ba5d0cfe11eed5850190ce46e71cf003996391618ad4eac2e0a54e260d264b8f8f9a02f53ec7cc7')
options=(!emptydirs)
-prepare() {
- cd "${pkgname}-${pkgver}"
- mkdir -p build
-}
-
build() {
- cd "${pkgname}-${pkgver}/build"
-
cmake \
- -D CMAKE_INSTALL_PREFIX="/usr" \
- -D BUILD_CLI_EXECUTABLES=ON \
- -D BUILD_PYTHON_BINDINGS=ON \
- -D BUILD_TESTS=OFF \
- -D USE_OPENMP=ON \
- ..
- make
+ -S ${pkgname}-${pkgver} \
+ -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_STANDARD=14 \
+ -DBUILD_CLI_EXECUTABLES=ON \
+ -DBUILD_PYTHON_BINDINGS=ON \
+ -DBUILD_TESTS=OFF \
+ -DUSE_OPENMP=ON
+ cmake --build build --target all
}
package() {
- cd "${pkgname}-${pkgver}/build"
-
- make DESTDIR="$pkgdir" install
-
- install -m 755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m 644 ../LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}"
+ DESTDIR="${pkgdir}" cmake --build build --target install
+ install -Dm 644 ${pkgname}-${pkgver}/LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}