summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Born2018-07-06 21:11:14 +0200
committerPhilipp Born2018-07-06 21:11:14 +0200
commitfaa9489e20a0cde452a833ad91ed766ee66df861 (patch)
tree83e48cce32e9af89f1dca29788b10eabe22c9f80
downloadaur-faa9489e20a0cde452a833ad91ed766ee66df861.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--grub-imageboot.install24
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1651375ccba9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Jul 6 19:08:53 UTC 2018
+pkgbase = grub-imageboot
+ pkgdesc = grub2 script to automatically add boot entries for iso images placed in /boot/images/
+ pkgver = 0.6
+ pkgrel = 2
+ url = https://launchpad.net/ubuntu/+source/grub-imageboot/
+ install = grub-imageboot.install
+ arch = any
+ license = GPL
+ depends = syslinux
+ depends = grub
+ source = https://raw.githubusercontent.com/formorer/grub-imageboot/529ac5d2bf91e7da8c31b9e15f37702127bddc1c/bin/60_grub-imageboot
+ source = https://raw.githubusercontent.com/formorer/grub-imageboot/529ac5d2bf91e7da8c31b9e15f37702127bddc1c/etc/grub-imageboot
+ sha256sums = 462a9720ffa13ea9378bc485ecc1a88cbee59534a256627e9ba4ce029ed61b39
+ sha256sums = 12602cea7b5d5b434007b891730a5071c3d2a06ed1cc225932e91d8a5d1f6c20
+
+pkgname = grub-imageboot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f56af6d29099
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Philipp Born <philipp@tamcore.eu>
+# Contributor: Max Roder <maxroder@web.de>
+
+pkgname='grub-imageboot'
+pkgver='0.6'
+pkgrel='2'
+pkgdesc="grub2 script to automatically add boot entries for iso images placed in /boot/images/"
+url="https://launchpad.net/ubuntu/+source/grub-imageboot/"
+arch=('any')
+license=('GPL')
+depends=('syslinux' 'grub')
+install='grub-imageboot.install'
+_commit='529ac5d2bf91e7da8c31b9e15f37702127bddc1c'
+source=("https://raw.githubusercontent.com/formorer/grub-imageboot/${_commit}/bin/60_grub-imageboot"
+ "https://raw.githubusercontent.com/formorer/grub-imageboot/${_commit}/etc/grub-imageboot")
+sha256sums=('462a9720ffa13ea9378bc485ecc1a88cbee59534a256627e9ba4ce029ed61b39'
+ '12602cea7b5d5b434007b891730a5071c3d2a06ed1cc225932e91d8a5d1f6c20')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # patch file
+ sed -i 's/\/usr\/lib\/grub/\/usr\/share\/grub/g' bin/60_grub-imageboot
+
+ install -Dm755 bin/60_grub-imageboot ${pkgdir}/etc/grub.d/60_grub-imageboot
+ install -Dm644 etc/grub-imageboot ${pkgdir}/etc/default/grub-imageboot
+ install -d ${pkgdir}/boot/images
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/grub-imageboot.install b/grub-imageboot.install
new file mode 100644
index 000000000000..a1ac38887004
--- /dev/null
+++ b/grub-imageboot.install
@@ -0,0 +1,24 @@
+post_install() {
+ cp /usr/lib/syslinux/bios/memdisk /boot/
+
+ echo "------------------------------------------------------------"
+ echo "> Place live iso images you want to boot in /boot/images/"
+ echo "> To have them added to grub automatically, run"
+ echo "> grub-mkconfig -o /boot/grub/grub.cfg"
+ echo "------------------------------------------------------------"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ rm /boot/memdisk
+ grub-mkconfig -o /boot/grub/grub.cfg
+
+ echo "------------------------------------------------------------"
+ echo "> You may want to remove your iso images in /boot/images/"
+ echo "------------------------------------------------------------"
+}
+
+# vim:set ts=2 sw=2 et: