summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-17 17:13:59 -0500
committerLuis Martinez2021-10-17 17:13:59 -0500
commitfab59b220128ee9d0be0946d554cfbd4967cd8fa (patch)
treec45d7697a2092d346a7f25707151e9508ba048ff
parentc1b532f1f78debb3fc14e59b167e3ce9ecd96345 (diff)
downloadaur-fab59b220128ee9d0be0946d554cfbd4967cd8fa.tar.gz
package cleanup
* added lua-succulent dependency
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD50
2 files changed, 33 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc4923aa2cb4..3db6c98b9280 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hilbish-git
- pkgdesc = A shell written in Go and extended with Lua
- pkgver = 0.5.0.r0.g36ea20b
- pkgrel = 2
+ pkgdesc = The flower shell for Lua users
+ pkgver = 0.5.1.r64.gb97e1ef
+ pkgrel = 1
url = https://github.com/rosettea/hilbish
install = hilbish-git.install
arch = x86_64
@@ -10,11 +10,13 @@ pkgbase = hilbish-git
makedepends = git
makedepends = go>=1.16
depends = readline
- depends = lua51-lunacolors-git
- optdepends = lua
+ depends = lua-lunacolors
+ depends = lua-succulent
provides = hilbish
conflicts = hilbish
- source = hilbish-git::git+https://github.com/rosettea/hilbish
+ options = !emptydirs
+ source = hilbish-git::git+https://github.com/rosettea/hilbish?signed
+ validpgpkeys = 098F50DFBCEEC71A4EAB6DA450EE40A2809851F5
sha256sums = SKIP
pkgname = hilbish-git
diff --git a/PKGBUILD b/PKGBUILD
index d4879bf25ede..9e04786d149b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,45 @@
-# Maintainer: lmartinez-mirror
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
pkgname=hilbish-git
-_pkgname=${pkgname%-git}
-pkgver=0.5.0.r0.g36ea20b
-pkgrel=2
-pkgdesc="A shell written in Go and extended with Lua"
+pkgver=0.5.1.r64.gb97e1ef
+pkgrel=1
+pkgdesc="The flower shell for Lua users"
arch=('x86_64' 'aarch64')
url="https://github.com/rosettea/hilbish"
license=('MIT')
-depends=('readline' 'lua51-lunacolors-git')
+depends=('readline' 'lua-lunacolors' 'lua-succulent')
makedepends=('git' 'go>=1.16')
-optdepends=('lua')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
install="$pkgname.install"
-source=("$pkgname::git+$url")
+options=('!emptydirs')
+source=("$pkgname::git+$url?signed")
sha256sums=('SKIP')
+validpgpkeys=('098F50DFBCEEC71A4EAB6DA450EE40A2809851F5')
pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+ git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
prepare() {
- cd "$pkgname"
- sed -i '\|/etc/shells|d' Makefile
+ cd "$pkgname"
+ sed -i '\|/etc/shells|d' Makefile
}
build() {
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- cd "$pkgname"
- make dev
+ cd "$pkgname"
+ make dev
}
package() {
- cd "$pkgname"
- DESTDIR="$pkgdir/" make install
- install -Dm 444 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm 444 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ cd "$pkgname"
+ DESTDIR="$pkgdir/" make install
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}