summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-03-05 16:50:33 +0800
committerPumpkinCheshire2021-03-05 16:50:33 +0800
commitfac1002adf959515e6f4138d9f412ef2a2faa1d3 (patch)
tree4c0e89936ad83559f5547afb2374de27680918da
downloadaur-fac1002adf959515e6f4138d9f412ef2a2faa1d3.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1447150b5248
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-termplotlib
+ pkgdesc = Plotting on the command line
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = https://github.com/nschloe/termplotlib
+ arch = any
+ license = GPL
+ makedepends = python
+ makedepends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/t/termplotlib/termplotlib-0.3.4.tar.gz
+ sha256sums = b1ebe3b31ac554db249c2b4cf042b7ba5363f49eeb36c4d1c5e4f15db9fc20ea
+
+pkgname = python-termplotlib
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9be8402336f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: PumpkinCheshire <sollyonzou at gmail dot com>
+
+pkgname=python-termplotlib
+_name=termplotlib
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="Plotting on the command line"
+arch=('any')
+url="https://github.com/nschloe/termplotlib"
+license=('GPL')
+makedepends=('python'
+ 'python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('b1ebe3b31ac554db249c2b4cf042b7ba5363f49eeb36c4d1c5e4f15db9fc20ea')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -c "from setuptools import setup; setup()" build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python -c "from setuptools import setup; setup();" install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+}