summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2018-07-07 22:43:25 -0600
committerSumner Evans2018-07-07 22:43:25 -0600
commitfaf51690186e8792f9e34339d238a5c05156b93b (patch)
treec302579e62af8a8acb705b5980837f1405e03aae
downloadaur-faf51690186e8792f9e34339d238a5c05156b93b.tar.gz
v0.6.1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore19
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD26
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e97f1e93f16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pdfkit
+ pkgdesc = Wkhtmltopdf python wrapper to convert html to pdf using the webkit rendering engine and qt
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/JazzCore/python-pdfkit
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = wkhtmltopdf
+ source = https://files.pythonhosted.org/packages/source/p/pdfkit/pdfkit-0.6.1.tar.gz
+ sha256sums = ef1da35b78d534197e7ce4a604a4a190e9aa769e56634957535f3479a50d8cd1
+
+pkgname = python-pdfkit
+ depends = python
+ depends = wkhtmltopdf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..92d3543c2fed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..cd3176fb3e1c
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,2 @@
+all:
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebbacecb9250
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sumner Evans <sumner.evans98 at gmail dot com>
+
+pkgbase=('python-pdfkit')
+pkgname=('python-pdfkit')
+_module='pdfkit'
+pkgver='0.6.1'
+pkgrel=1
+pkgdesc="Wkhtmltopdf python wrapper to convert html to pdf using the webkit rendering engine and qt"
+url="https://github.com/JazzCore/python-pdfkit"
+depends=('python' 'wkhtmltopdf')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/p/pdfkit/pdfkit-${pkgver}.tar.gz")
+sha256sums=('ef1da35b78d534197e7ce4a604a4a190e9aa769e56634957535f3479a50d8cd1')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}