summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-02-19 15:59:48 +0100
committerPhilipp A2022-02-19 15:59:48 +0100
commitfaf767a3c7eefa9ac91f708b845952275aef2cb9 (patch)
tree60e244154e8ef6370ef559221c9b2262f06220f4
parent20e7e79c58c2f372be4124e0dfdcbaae3a3e218d (diff)
downloadaur-faf767a3c7eefa9ac91f708b845952275aef2cb9.tar.gz
build from source
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bbd56ee26a1..a6102181a1ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = scanpy-scripts
pkgdesc = Scripts for using scanpy from the command line
pkgver = 1.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ebi-gene-expression-group/scanpy-scripts
arch = any
license = MIT
- makedepends = install-wheel-scripts
+ makedepends = python-build
+ makedepends = python-installer
depends = scanpy
depends = python-click
- noextract = scanpy_scripts-1.1.3-py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py3/s/scanpy-scripts/scanpy_scripts-1.1.3-py3-none-any.whl
- sha256sums = c3dddc6acb90cfc610fb87da9e0407b10541c904fc4d21a3850941a094604675
+ source = https://files.pythonhosted.org/packages/source/s/scanpy-scripts/scanpy-scripts-1.1.3.tar.gz
+ sha256sums = 96eb39bedb5cd075509247d770cfd951e57f2834248bf1e6896c55e7fe2c524f
pkgname = scanpy-scripts
diff --git a/.gitignore b/.gitignore
index cb3cc40a81f9..c5d85b20091f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/src/
/pkg/
-/*.pkg.tar.xz
-/*.whl
+/*.pkg.*
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index b7944c86d80b..0149078133f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
pkgname=scanpy-scripts
pkgver=1.1.3
-pkgrel=1
+pkgrel=2
pkgdesc='Scripts for using scanpy from the command line'
arch=(any)
url='https://github.com/ebi-gene-expression-group/scanpy-scripts'
license=(MIT)
depends=(scanpy python-click)
-makedepends=(install-wheel-scripts)
-_pyarch=py3
-_wheel="${pkgname/-/_}-$pkgver-$_pyarch-none-any.whl"
-source=("https://files.pythonhosted.org/packages/$_pyarch/${pkgname::1}/$pkgname/$_wheel")
-sha256sums=('c3dddc6acb90cfc610fb87da9e0407b10541c904fc4d21a3850941a094604675')
-noextract=("$_wheel")
+makedepends=(python-build python-installer)
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('96eb39bedb5cd075509247d770cfd951e57f2834248bf1e6896c55e7fe2c524f')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
- mkdir -p "$site"
- unzip "$_wheel" -d "$site"
- install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}