summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2023-04-30 12:47:30 +0000
committerOmar Pakker2023-04-30 12:47:30 +0000
commitfafe9491f5154e5eee79acad4edca3b2110eee4e (patch)
tree90a5e14cd171d49798de3e8c95dc86937d5a6454
parentf90bc84f5bb643d89234d34fd72e04608704da1f (diff)
downloadaur-fafe9491f5154e5eee79acad4edca3b2110eee4e.tar.gz
Initial version.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD81
2 files changed, 50 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d91388536e83..31aa64bb4e52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtwebkit
pkgdesc = An open source web browser engine (Qt port)
pkgver = 2.3.4
- pkgrel = 7
+ pkgrel = 8
url = http://trac.webkit.org/wiki/QtWebKit
arch = i686
arch = x86_64
@@ -18,16 +18,19 @@ pkgbase = qtwebkit
conflicts = qt<4.8
source = https://sources.archlinux.org/other/packages/qtwebkit/qtwebkit-2.3.4.tar.xz
source = https://download.qt.io/archive/qt/4.8/4.8.7/qt-everywhere-opensource-src-4.8.7.tar.gz
+ source = https://src.fedoraproject.org/rpms/qtwebkit/raw/rawhide/f/webkit-qtwebkit-23-gcc5.patch
+ source = https://src.fedoraproject.org/rpms/qtwebkit/raw/rawhide/f/webkit-qtwebkit-23-glib2.patch
+ source = https://src.fedoraproject.org/rpms/qtwebkit/raw/rawhide/f/qtwebkit-bison-3.7.patch
source = use-python2.patch
source = qwebview.patch
- source = gcc-5.patch
source = fix-build-in-usr.patch
sha1sums = 31bc60de1cf26bb0766d539b4d564651ddbb0650
sha1sums = 76aef40335c0701e5be7bb3a9101df5d22fe3666
+ sha1sums = 4b3f92a914674ef311b2a7c0ca329d01e1af76cf
+ sha1sums = 67a3f86a7981be01baa507bbd091be048cdf18af
+ sha1sums = 77b258bd267b070f21f4b7d5b480238c300020fb
sha1sums = 315b6ff603f35e5492a036f7082f6aa075dfb607
sha1sums = c3df6107233f466a032e36681cee07f16536657c
- sha1sums = 5d506578ea30daeeeb1e91ab83876fe6d5669715
sha1sums = 412a58db507fa14268c9f30627d62fd448f9dccb
pkgname = qtwebkit
-
diff --git a/PKGBUILD b/PKGBUILD
index dd4d664e3584..58c04c3fd7e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 252776 2015-12-06 12:09:40Z bpiotrowski $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Maintainer: Omar Pakker <archlinux@opakker.nl>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=qtwebkit
pkgver=2.3.4
-pkgrel=7
+pkgrel=8
arch=('i686' 'x86_64')
url='http://trac.webkit.org/wiki/QtWebKit'
pkgdesc='An open source web browser engine (Qt port)'
@@ -14,60 +14,65 @@ conflicts=('qt<4.8')
_qtver=4.8.7
source=("https://sources.archlinux.org/other/packages/${pkgname}/${pkgname}-${pkgver}.tar.xz"
"https://download.qt.io/archive/qt/4.8/${_qtver}/qt-everywhere-opensource-src-${_qtver}.tar.gz"
- 'use-python2.patch'
- 'qwebview.patch' 'gcc-5.patch' 'fix-build-in-usr.patch')
+ "https://src.fedoraproject.org/rpms/qtwebkit/raw/rawhide/f/webkit-qtwebkit-23-gcc5.patch"
+ "https://src.fedoraproject.org/rpms/qtwebkit/raw/rawhide/f/webkit-qtwebkit-23-glib2.patch"
+ "https://src.fedoraproject.org/rpms/qtwebkit/raw/rawhide/f/qtwebkit-bison-3.7.patch"
+ 'use-python2.patch' 'qwebview.patch' 'fix-build-in-usr.patch')
sha1sums=('31bc60de1cf26bb0766d539b4d564651ddbb0650'
'76aef40335c0701e5be7bb3a9101df5d22fe3666'
+ '4b3f92a914674ef311b2a7c0ca329d01e1af76cf'
+ '67a3f86a7981be01baa507bbd091be048cdf18af'
+ '77b258bd267b070f21f4b7d5b480238c300020fb'
'315b6ff603f35e5492a036f7082f6aa075dfb607'
'c3df6107233f466a032e36681cee07f16536657c'
- '5d506578ea30daeeeb1e91ab83876fe6d5669715'
'412a58db507fa14268c9f30627d62fd448f9dccb')
prepare() {
- cd ${pkgname}-${pkgver}
- patch -p1 -i "${srcdir}"/use-python2.patch
- patch -p1 -i "${srcdir}"/fix-build-in-usr.patch
+ cd "${pkgname}"-"${pkgver}"
+ patch -p1 -i "${srcdir}"/use-python2.patch
+ patch -p1 -i "${srcdir}"/fix-build-in-usr.patch
-# Fix build with GCC 5 (Fedora)
- patch -p1 -i "$srcdir"/gcc-5.patch
+ # Fix build on Arch using additional patched (from Fedora)
+ patch -p1 -i "${srcdir}"/webkit-qtwebkit-23-gcc5.patch
+ patch -p1 -i "${srcdir}"/webkit-qtwebkit-23-glib2.patch
+ patch -p1 -i "${srcdir}"/qtwebkit-bison-3.7.patch
- cd ../qt-everywhere-opensource-src-${_qtver}
- patch -p1 -i "${srcdir}"/qwebview.patch
+ cd ../qt-everywhere-opensource-src-"${_qtver}"
+ patch -p1 -i "${srcdir}"/qwebview.patch
}
build() {
- cd ${pkgname}-${pkgver}
+ cd "${pkgname}"-"${pkgver}"
- OPTS="--no-webkit2 --no-xslt"
- if [ "${CARCH}" = "i686" ]; then
- # FS#33418
- OPTS="${OPTS} --no-force-sse2"
- fi
+ OPTS=( "--no-webkit2" "--no-xslt" )
+ if [ "${CARCH}" = "i686" ]; then
+ # FS#33418
+ OPTS+=( "--no-force-sse2" )
+ fi
- export QTDIR=/usr
- export PATH="/usr/lib/qt4/bin:$PATH"
- Tools/Scripts/build-webkit --qt \
- --makeargs="${MAKEFLAGS}" \
- --prefix=/usr \
- ${OPTS}
+ export QTDIR=/usr
+ export PATH="/usr/lib/qt4/bin:$PATH"
+ Tools/Scripts/build-webkit --qt \
+ --makeargs="${MAKEFLAGS}" \
+ --prefix=/usr \
+ "${OPTS[@]}"
- # Build the QWebView plugin (FS#27914)
- cd ../qt-everywhere-opensource-src-${_qtver}/tools/designer/src/plugins/qwebview
- qmake-qt4
- make
+ # Build the QWebView plugin (FS#27914)
+ cd ../qt-everywhere-opensource-src-"${_qtver}"/tools/designer/src/plugins/qwebview
+ qmake-qt4
+ make
}
package() {
- cd ${pkgname}-${pkgver}
- make INSTALL_ROOT="${pkgdir}" -C WebKitBuild/Release install
+ cd "${pkgname}"-"${pkgver}"
+ make INSTALL_ROOT="${pkgdir}" -C WebKitBuild/Release install
- cd ../qt-everywhere-opensource-src-${_qtver}/tools/designer/src/plugins/qwebview
- make INSTALL_ROOT="${pkgdir}" install
+ cd ../qt-everywhere-opensource-src-"${_qtver}"/tools/designer/src/plugins/qwebview
+ make INSTALL_ROOT="${pkgdir}" install
- # Fix wrong libs path in pkgconfig file
- perl -pi -e "s, -L${srcdir}/?\S+,,g" "${pkgdir}"/usr/lib/pkgconfig/QtWebKit.pc
+ # Fix wrong libs path in pkgconfig file
+ perl -pi -e "s, -L${srcdir}/?\S+,,g" "${pkgdir}"/usr/lib/pkgconfig/QtWebKit.pc
- # Fix wrong path in prl file
- sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' "${pkgdir}"/usr/lib/libQtWebKit.prl
+ # Fix wrong path in prl file
+ sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' "${pkgdir}"/usr/lib/libQtWebKit.prl
}
-