summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Muehlhaeuser2019-05-31 15:37:09 +0200
committerChristian Muehlhaeuser2019-05-31 15:37:09 +0200
commitfafee74e4ca494eac5c7c2651f7950c83722045a (patch)
tree64603f1c532f41abade45254caa35c7847e349aa
parented8743ec60b7dc003f0706db0c00c6f474644092 (diff)
downloadaur-fafee74e4ca494eac5c7c2651f7950c83722045a.tar.gz
Fixed PKGBUILD and bumped version to 0.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fae5b314820..852b559ff286 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = beehive
pkgdesc = A flexible event and agent system with lots of bees
- pkgver = 0.3.1
- pkgrel = 2
+ pkgver = 0.3.2
+ pkgrel = 1
url = https://github.com/muesli/beehive
install = beehive.install
arch = x86_64
arch = i686
license = AGPL3
makedepends = go
+ makedepends = make
options = !strip
options = !emptydirs
- source = beehive-0.3.1::git+https://github.com/muesli/beehive#tag=v0.3.1
+ options = !makeflags
+ source = beehive-0.3.2::git+https://github.com/muesli/beehive#tag=v0.3.2
source = beehive.install
source = beehive.service
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index edd0dcb4083b..566b5f51c13d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Dennis Stengele <dennis@stengele.me>
+# Maintainer: Christian Muehlhaeuser <muesli at gmail dot com>
pkgname=beehive
-pkgver=0.3.1
-pkgrel=2
+pkgver=0.3.2
+pkgrel=1
pkgdesc="A flexible event and agent system with lots of bees"
arch=('x86_64' 'i686')
url="https://github.com/muesli/beehive"
license=('AGPL3')
-makedepends=('go')
-options=('!strip' '!emptydirs')
+makedepends=('go' 'make')
+options=('!strip' '!emptydirs' '!makeflags')
install=beehive.install
source=("$pkgname-$pkgver::git+https://github.com/muesli/beehive#tag=v$pkgver"
"beehive.install"
@@ -18,17 +19,19 @@ sha256sums=('SKIP'
'0b25ced04449720cba74c0c13bc6c0b75ff6f34bcaad58889745f572f66e7160')
build() {
- mkdir -p gopath/src/github.com/muesli
- ln -rTsf $pkgname-$pkgver gopath/src/github.com/muesli/$pkgname
export GOPATH="$srcdir"/gopath
export GO111MODULE=on
- cd gopath/src/github.com/muesli/$pkgname
+
+ mkdir -p "$GOPATH"/bin
+ cd "$srcdir"/$pkgname-$pkgver
make
}
check() {
export GOPATH="$srcdir"/gopath
- cd gopath/src/github.com/muesli/$pkgname
+ export GO111MODULE=on
+
+ cd "$srcdir"/$pkgname-$pkgver
make test
}