summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgammy2021-12-30 13:45:05 +0100
committergammy2021-12-30 13:45:05 +0100
commitfb266475cfaa98eae2e93f0cf9b54beab35a3fbf (patch)
tree2b8ba8e9933da1943f8224bd272c1a21b6d7ac4d
parente0c6fef1d3d4b2a187a563389e8b79e71e21c3b2 (diff)
downloadaur-fb266475cfaa98eae2e93f0cf9b54beab35a3fbf.tar.gz
Update for ucon 2.2.2. This removes the necessity for pulling and applying change_mem2.patch and V64_send_gauge.patch which have now been applied upstream.
-rw-r--r--PKGBUILD22
1 files changed, 4 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b07da0f2becc..eb350591aa1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: robb_force <robb_force@holybuffalo.net>
pkgname=ucon64
-pkgver=2.2.1
-pkgrel=2
+pkgver=2.2.2
+pkgrel=1
pkgdesc="A ROM backup tool and emulator's Swiss Army knife program."
arch=('i686' 'x86_64')
url="https://ucon64.sourceforge.io/index.php"
@@ -13,27 +13,13 @@ license=('GPL')
depends=('zlib' 'libusb-compat')
optdepends=('libieee1284: libcd64 enhancements')
source=(https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}-src.tar.gz)
-sha256sums=('e814f427a59866e16fe757bf4af51004ac68be29cabd78944590878f1df73f79')
-
-# Apply minor patches (which will be included in the next release)
-# change_mem2.patch affects 64-bit systems, the bug of which was found just a
-# few days after the release of 2.2.1.
-# V64_send_gauge.patch fixes a minor issue with the progressbar when uploading
-# ROMs to the Doctor V64.
-source+=("https://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgname}-${pkgver}/patches/change_mem2.patch"
- "https://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgname}-${pkgver}/patches/V64_send_gauge.patch")
-sha256sums+=('65ff85255878e077c2e5fc57565cf0b93833ce8ac03bf81d46ba91ec837accf7'
- 'b60a0eb53be238aa8d3a6b33e4708b8a2f953f11603a1a492b8b8b3cfd623d66')
+sha256sums=('e100ad4a30f6c19abde98e361c6a0ecac4e40477f54cfb75498c5ccd21fb3a18')
srcroot="${pkgname}-${pkgver}-src/src"
prepare()
{
- patch -d "${srcdir}" -p2 < ../aur_discmage_path.patch
-
- # XXX Remember to remove these patches on the next release (>2.2.1)
- patch -d "${srcdir}" -p0 < change_mem2.patch
- patch -d "${srcdir}" -p0 < V64_send_gauge.patch
+ patch -d "${srcroot}" -p2 < ../aur_discmage_path.patch
}
build()