summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas P2019-07-19 10:23:39 +0200
committerThomas P2019-07-19 10:23:39 +0200
commitfb47e6b1dd5dd063a90ac0111b9e17397b999c74 (patch)
tree3fd37fe8d513c2e82c54d737246b3ff3aff8d35e
parent5ae535b14bb2648861665c000ed4124e4b1e8b30 (diff)
downloadaur-fb47e6b1dd5dd063a90ac0111b9e17397b999c74.tar.gz
Edit the build script to fetch the latest version from the Github repo
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4ae1a250e3d..89fed798540c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = safeeyes
- pkgdesc = A Free and Open Source tool for Linux users to reduce and prevent repetitive strain injury (RSI).
- pkgver = 2.0.9
+pkgbase = safeeyes-git
+ pkgdesc = A Free and Open Source tool for Linux users to reduce and prevent repetitive strain injury (RSI). Latest version from the git repository
+ pkgver = v2.0.9.r14.g098f320
pkgrel = 1
url = https://github.com/slgobinath/SafeEyes
arch = any
@@ -18,8 +18,9 @@ pkgbase = safeeyes
depends = python-xlib
depends = xorg-xprop
optdepends = xprintidle: better idle timer
- source = safeeyes-2.0.9.tar.gz::https://github.com/slgobinath/SafeEyes/archive/v2.0.9.tar.gz
- sha1sums = 3b205185ad027e15d0016daa9c503e39d60233dc
+ conflicts = safeeyes
+ source = git+https://github.com/slgobinath/SafeEyes.git
+ sha1sums = SKIP
-pkgname = safeeyes
+pkgname = safeeyes-git
diff --git a/PKGBUILD b/PKGBUILD
index 1513555b61f1..5c7e7723d539 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Yamakaky <yamakaky@yamaworld_fr>
-pkgname=safeeyes
-pkgver=2.0.9
+# Original Author: Yamakaky <yamakaky@yamaworld_fr>
+# Edited by: Thomas <tpxp@live.fr> for the git version
+pkgname=safeeyes-git
+pkgver="v2.0.9.r14.g098f320"
pkgrel=1
-pkgdesc="A Free and Open Source tool for Linux users to reduce and prevent repetitive strain injury (RSI)."
+pkgdesc="A Free and Open Source tool for Linux users to reduce and prevent repetitive strain injury (RSI). Latest version from the git repository"
arch=("any")
url="https://github.com/slgobinath/SafeEyes"
license=("GPL3")
@@ -16,12 +17,18 @@ depends=("alsa-utils"
"python-psutil"
"python-xlib"
"xorg-xprop")
+conflicts=("safeeyes")
makedepends=("python-setuptools" "python-pip")
optdepends=("xprintidle: better idle timer")
-source=(safeeyes-$pkgver.tar.gz::"https://github.com/slgobinath/SafeEyes/archive/v$pkgver.tar.gz")
-sha1sums=('3b205185ad027e15d0016daa9c503e39d60233dc')
+source=("git+https://github.com/slgobinath/SafeEyes.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/SafeEyes"
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
package() {
- cd "$srcdir/SafeEyes-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/SafeEyes"
+ python setup.py install --root="$pkgdir/" --optimize=1
}