summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-08 09:17:35 +0100
committerWill Handley2017-10-08 09:17:35 +0100
commitfb9145156f3d86bc862166abd00ae35898044d28 (patch)
treeb58e54b933f1e2f54bced7c9ea727d97f440eff6
downloadaur-fb9145156f3d86bc862166abd00ae35898044d28.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e09fe0854f2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lalxml
+ pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lalxml
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = https://wiki.ligo.org/DASWG/LALSuiteInstall
+ arch = any
+ groups = lalsuite
+ license = unknown
+ depends = lalcore
+ options = !emptydirs
+ source = http://software.ligo.org/lscsoft/source/lalsuite/lalxml-1.2.4.tar.xz
+ sha256sums = 5509bcc9cbce0b497036d3fc87628d1cbaa9f33af20cf33609cabd9c6ee398f1
+
+pkgname = lalxml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28d0c667c0f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=lalxml
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. lalxml"
+arch=(any)
+url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
+license=('unknown')
+groups=('lalsuite')
+depends=('lalcore')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("http://software.ligo.org/lscsoft/source/lalsuite/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('5509bcc9cbce0b497036d3fc87628d1cbaa9f33af20cf33609cabd9c6ee398f1')
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ sed -i 's/\-Werror//g' configure
+ ./configure --prefix=$pkgdir/usr
+ make -j
+ make install
+}