summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-08 20:33:17 +0200
committerStefan Husmann2015-06-08 20:33:17 +0200
commitfbf2347bb91e3087e6bc7c9694c7588260a45230 (patch)
treeb291067358058dddf0c1ca6515c8d0676057b9e5
downloadaur-fbf2347bb91e3087e6bc7c9694c7588260a45230.tar.gz
initial version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c794f53bf68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = clisp-new-clx
+ pkgdesc = ANSI Common Lisp interpreter, compiler and debugger
+ pkgver = 2.49
+ pkgrel = 5
+ url = http://clisp.cons.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = ffcall
+ depends = readline
+ depends = libsigsegv
+ provides = common-lisp
+ provides = clisp
+ conflicts = clisp
+ options = !makeflags
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/sourceforge/clisp/clisp-2.49.tar.bz2
+ md5sums = 1962b99d5e530390ec3829236d168649
+
+pkgname = clisp-new-clx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c78899baf8d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor: Alexej Magura <agm2819*gmail*>
+# Contributor: Theomachos <theomachos[at]pindundin[dot]de>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=clisp-new-clx
+_pkgname=clisp
+pkgver=2.49
+pkgrel=5
+pkgdesc="ANSI Common Lisp interpreter, compiler and debugger"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://clisp.cons.org/"
+depends=('readline' 'libsigsegv')
+provides=('common-lisp' 'clisp')
+conflicts=('clisp')
+makedepends=('ffcall')
+options=('!makeflags' '!emptydirs')
+source=("http://downloads.sourceforge.net/sourceforge/clisp/clisp-${pkgver}.tar.bz2")
+md5sums=('1962b99d5e530390ec3829236d168649')
+
+build() {
+ cd $srcdir/${_pkgname}-${pkgver}
+ ./configure --prefix=/usr --with-readline \
+ --with-module=clx/new-clx --with-ffcall src
+ cd src
+ ./makemake --prefix=/usr --with-readline --with-module=clx/new-clx \
+ --with-ffcall --with-dynamic-ffi > Makefile
+ make
+ sed -i 's,http://www.lisp.org/HyperSpec/,http://www.lispworks.com/reference/HyperSpec/,g' config.lisp
+ make
+}
+
+check() {
+ cd $srcdir/${_pkgname}-${pkgver}/src
+ make check
+}
+
+package() {
+ cd $srcdir/${_pkgname}-${pkgver}/src
+ make DESTDIR=$pkgdir install
+}
+