summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2022-06-21 20:31:52 +0200
committerkleintux2022-06-21 20:31:52 +0200
commitfc522addcc133cf07a672532fe4385c14477c68d (patch)
tree14a6c5db7c10167506b0acfa305e3163a3178ed6
parentba8a2c7c5af944f151c7d80ca12b2e7a59b0f900 (diff)
downloadaur-fc522addcc133cf07a672532fe4385c14477c68d.tar.gz
adopted. updated to 3.2.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efbf44cc7218..eacb1098dc86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emoj
pkgdesc = Find relevant emoji from text on the command-line
- pkgver = 3.0.1
+ pkgver = 3.2.0
pkgrel = 1
url = https://github.com/sindresorhus/emoj
arch = any
@@ -8,9 +8,8 @@ pkgbase = emoj
makedepends = npm
depends = nodejs
depends = xsel
- noextract = emoj-3.0.1.tgz
- source = https://github.com/sindresorhus/emoj/archive/v3.0.1.tar.gz
- sha1sums = 41ada7b8dc827727505c12deea0344cfa8f27ebd
+ noextract = emoj-3.2.0.tgz
+ source = https://github.com/sindresorhus/emoj/archive/v3.2.0.tar.gz
+ sha256sums = 68e41facffe3abcdee0e753564349d5b543c1b22556ab645a83b4af641683c86
pkgname = emoj
-
diff --git a/PKGBUILD b/PKGBUILD
index 834ad31be089..a1afe336ee34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
-# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
pkgname=emoj
-pkgver=3.0.1
+pkgver=3.2.0
pkgrel=1
pkgdesc="Find relevant emoji from text on the command-line"
arch=("any")
-url="https://github.com/sindresorhus/emoj"
+url="https://github.com/sindresorhus/${pkgname}"
license=('MIT')
depends=('nodejs' 'xsel')
makedepends=('npm')
-source=(https://github.com/sindresorhus/$pkgname/archive/v$pkgver.tar.gz)
+source=(https://github.com/sindresorhus/${pkgname}/archive/v${pkgver}.tar.gz)
noextract=($pkgname-$pkgver.tgz)
-sha1sums=('41ada7b8dc827727505c12deea0344cfa8f27ebd')
+sha256sums=('68e41facffe3abcdee0e753564349d5b543c1b22556ab645a83b4af641683c86')
package() {
- cd $srcdir
-
- install -dm 755 "$pkgdir/usr/lib/node_modules/"
- cd "$pkgdir/usr/lib/node_modules/"
- npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+ install -dm 755 "${pkgdir}/usr/lib/node_modules/"
+ cd "${pkgdir}/usr/lib/node_modules/"
+ npm install -g --prefix "${pkgdir}/usr" ${pkgname}@${pkgver}
}