aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-01-10 23:09:23 -0500
committerJames An2015-01-10 23:09:23 -0500
commitfc95a6b12e890ccde19eeb838f9cb2e0ed8d0ce7 (patch)
tree6209a0a3c5a286d0d81d1a4350db0ba9d734363b
downloadaur-fc95a6b12e890ccde19eeb838f9cb2e0ed8d0ce7.tar.gz
Added new AUR package, systemd-resolved-public-dns.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
-rw-r--r--comodo-secure-dns.conf2
-rw-r--r--dns-advantage.conf2
-rw-r--r--google-public-dns.conf2
-rw-r--r--norton-dns.conf2
-rw-r--r--opendns.conf2
7 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9de3705d9647
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = systemd-resolved-public-dns
+ pkgdesc = Config files defining IPv4 public DNS for systemd's DNS resolver
+ pkgver = 1
+ pkgrel = 2
+ url = https://github.com/jamesan/aur-pkgs/tree/master/systemd-resolved-public-dns
+ arch = any
+ license = GPL
+ source = comodo-secure-dns.conf
+ source = dns-advantage.conf
+ source = google-public-dns.conf
+ source = norton-dns.conf
+ source = opendns.conf
+ md5sums = f1b6009234ac60f118ee92d332efc00b
+ md5sums = 92ae9aef034229d1ae1a7356760dc5b0
+ md5sums = 915793b1f0dafa3d1c2c22ab224b353d
+ md5sums = 1aafbfd2514aa39351d38c266085e320
+ md5sums = 910578ec675036e85cf493a9bfd2afb0
+
+pkgname = systemd-resolved-public-dns
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bde55a7285f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=systemd-resolved-public-dns
+pkgver=1
+pkgrel=1
+pkgdesc="Config files defining public DNS for systemd's DNS resolver"
+arch=('any')
+url="https://github.com/jamesan/aur-pkgs/tree/master/$pkgname"
+license=('GPL')
+source=(
+ comodo-secure-dns.conf
+ dns-advantage.conf
+ google-public-dns.conf
+ norton-dns.conf
+ opendns.conf
+)
+md5sums=(
+ 'f1b6009234ac60f118ee92d332efc00b'
+ '92ae9aef034229d1ae1a7356760dc5b0'
+ '203d64932780362d88b881a7b986872a'
+ '1aafbfd2514aa39351d38c266085e320'
+ '910578ec675036e85cf493a9bfd2afb0'
+)
+
+package() {
+ for CONF in *.conf; do
+ install -Dm644 "$CONF" "$pkgdir/usr/lib/systemd/resolved.conf.d/$CONF"
+ done
+}
diff --git a/comodo-secure-dns.conf b/comodo-secure-dns.conf
new file mode 100644
index 000000000000..24a40714ffbf
--- /dev/null
+++ b/comodo-secure-dns.conf
@@ -0,0 +1,2 @@
+[Resolve]
+DNS=8.26.56.26 8.20.247.20
diff --git a/dns-advantage.conf b/dns-advantage.conf
new file mode 100644
index 000000000000..f18287d0a4d0
--- /dev/null
+++ b/dns-advantage.conf
@@ -0,0 +1,2 @@
+[Resolve]
+DNS=156.154.70.1 156.154.71.1
diff --git a/google-public-dns.conf b/google-public-dns.conf
new file mode 100644
index 000000000000..62fceb41f48d
--- /dev/null
+++ b/google-public-dns.conf
@@ -0,0 +1,2 @@
+[Resolve]
+DNS=8.8.8.8 8.8.4.4 2001:4860:4860::8888 2001:4860:4860::8844
diff --git a/norton-dns.conf b/norton-dns.conf
new file mode 100644
index 000000000000..0341342276f6
--- /dev/null
+++ b/norton-dns.conf
@@ -0,0 +1,2 @@
+[Resolve]
+DNS=198.153.192.1 198.153.194.1
diff --git a/opendns.conf b/opendns.conf
new file mode 100644
index 000000000000..d47f529220b6
--- /dev/null
+++ b/opendns.conf
@@ -0,0 +1,2 @@
+[Resolve]
+DNS=208.67.222.222 208.67.220.220