summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenz Steinert2019-12-01 19:07:13 +0100
committerLorenz Steinert2019-12-01 19:07:13 +0100
commitfca5fd95ed8936042df603d02e169d07a14a4a87 (patch)
tree58a2dae0adbf33ad6d54e6c115079370794fd646
parent20b817aa1915b5cd9c06f7e7fc35c1a19a0a4633 (diff)
downloadaur-fca5fd95ed8936042df603d02e169d07a14a4a87.tar.gz
factor out python2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 2 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 425874b30599..48f818de1e51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Fri Jan 27 22:53:56 UTC 2017
pkgbase = python-robot-detection
pkgdesc = Library for detecting if a HTTP User Agent header is likely to be a bot
pkgver = 0.4.0
@@ -8,7 +6,6 @@ pkgbase = python-robot-detection
arch = any
license = GPL
makedepends = python-setuptools
- makedepends = python2-setuptools
options = !emptydirs
source = https://github.com/rory/robot-detection/archive/v0.4.0.tar.gz
sha256sums = 9fa0423a890fd5856e5494076ba6e67abd2f4173d91c8b292819dfaa815b5060
@@ -16,6 +13,3 @@ pkgbase = python-robot-detection
pkgname = python-robot-detection
depends = python
-pkgname = python2-robot-detection
- depends = python2
-
diff --git a/PKGBUILD b/PKGBUILD
index 73ef48717a08..a9507a085e2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Simon Hanna <simon dot hanna AT serve-me DOT info>
-pkgname=('python-robot-detection' 'python2-robot-detection')
+pkgname=('python-robot-detection')
_pkgbase='robot-detection'
pkgver=0.4.0
pkgrel=1
@@ -11,7 +11,7 @@ license=('GPL')
options=(!emptydirs)
source=("https://github.com/rory/robot-detection/archive/v${pkgver}.tar.gz")
sha256sums=('9fa0423a890fd5856e5494076ba6e67abd2f4173d91c8b292819dfaa815b5060')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools')
package_python-robot-detection() {
depends=('python')
@@ -19,10 +19,4 @@ package_python-robot-detection() {
python setup.py install --root="$pkgdir/" --optimize=1
}
-package_python2-robot-detection() {
- depends=('python2')
- cd "$srcdir/$_pkgbase-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
-}
-
# vim:set ts=2 sw=2 et: