summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Dems2019-11-21 08:40:26 +0100
committerMaciej Dems2019-11-21 08:40:26 +0100
commitfcae676c0e61523f0c0a62a47afd3e2382b876e9 (patch)
tree531028296a22cda115b7b11569b0f6cb3428956b
parent0790091cd8284bd7bc240c62218ba49630228b33 (diff)
downloadaur-fcae676c0e61523f0c0a62a47afd3e2382b876e9.tar.gz
Added local package files to install
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--_pamac9
3 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0daafcdb9eff..c540772eae87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = pamac-zsh-completions
pkgdesc = ZSH completions for pamac
- pkgver = 0.2
+ pkgver = 0.3
pkgrel = 1
arch = any
license = GPL
depends = zsh
depends = pamac
source = _pamac
- sha256sums = 389bb461e89c5d803743d29c1dd1d263b3d5330aca18d80ae1a4dd9cc5addec6
+ sha256sums = 1f9252577ee50be1520df6cc01ce9e768f386823f9065dee91e5d3c57574a8f5
pkgname = pamac-zsh-completions
diff --git a/PKGBUILD b/PKGBUILD
index a719f13042e0..59a2e0b63007 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Maciej Dems <macdems@gmail.com>
pkgname=pamac-zsh-completions
-pkgver=0.2
+pkgver=0.3
pkgrel=1
pkgdesc="ZSH completions for pamac"
depends=('zsh' 'pamac')
license=('GPL')
arch=('any')
source=('_pamac')
-sha256sums=('389bb461e89c5d803743d29c1dd1d263b3d5330aca18d80ae1a4dd9cc5addec6')
+sha256sums=('1f9252577ee50be1520df6cc01ce9e768f386823f9065dee91e5d3c57574a8f5')
package() {
mkdir -p "${pkgdir}/usr/share/zsh/site-functions"
diff --git a/_pamac b/_pamac
index 4b95bdb23105..202ba7ed584c 100644
--- a/_pamac
+++ b/_pamac
@@ -79,6 +79,13 @@ _pamac_completions_installed_packages_and_groups() {
'pkgs:installed packages:_pamac_completions_installed_packages' \
'grps:installed groups:_pamac_completions_installed_groups'
}
+_pamac_completions_all_packages_groups_and_local() {
+ _alternative : \
+ 'pkgs:packages:_pamac_completions_all_packages' \
+ 'grps:groups:_pamac_completions_all_groups' \
+ 'locl:package files:_files -g "*.pkg.tar.(z|gz|bz|bz2|lrz|lz|lz4|lzop|xz|lzma)"'
+}
+
# provides completions for repository names
_pamac_completions_repositories() {
@@ -182,7 +189,7 @@ _pamac_command_install() {
"(--ignore)--ignore[ignore a package upgrade, multiple packages can be specified by separating them with a comma]:packages:_pamac_all_packages" \
"(--overwrite)--override[overwrite conflicting files, multiple patterns can be specified by separating them with a comma]:glob:_files" \
"(--no-confirm)--no-confirm[bypass any and all confirmation messages]" \
- "*:packages:_pamac_completions_all_packages_and_groups"
+ "*:packages:_pamac_completions_all_packages_groups_and_local"
}
_pamac_command_reinstall() {