summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJérémy "Vrakfall" Lecocq2018-11-02 06:13:01 +0100
committerJérémy "Vrakfall" Lecocq2018-11-02 06:13:01 +0100
commitfcb55dd0a1f0e83682befd0727836909b60456bb (patch)
tree15ccccd4dac8e8851b42d57ffc5b288f3672b24a
downloadaur-fcb55dd0a1f0e83682befd0727836909b60456bb.tar.gz
Android sources v28-r01. Imported from previous versions' packages.
Signed-off-by: Jérémy "Vrakfall" Lecocq <jeremy@artphotolaurent.be>
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD28
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd6e26dd80b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = android-sources-28
+ pkgdesc = Android SDK Sources, API-28
+ pkgver = 9.0.0_r01
+ pkgrel = 1
+ url = https://developer.android.com/studio/index.html
+ arch = any
+ license = custom
+ conflicts = android-sources=28
+ options = !strip
+ source = https://dl.google.com/android/repository/sources-28_r01.zip
+ sha256sums = 7c05aecdc5b56a8d30837ff80885e95736e455aef4d442a5f5f39fe9652250f0
+
+pkgname = android-sources-28
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c51efac612b0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+# IntelliJ project files
+.idea
+*.iml
+out
+gen
+
+# Generated files
+sources-*.zip
+android-sources-*.pkg.tar.xz
+src
+pkg \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b8459700a58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#@IgnoreInspection BashAddShebang
+# Maintainer: Jérémy "Vrakfall" Lecocq <jeremy at artphotolaurent dot be>
+# Contributor: Bence Hornák <hornak dot bence at gmail dot com>
+# Contributor: Philipp Wolfer <ph.wolfer@gmail.com>
+# Contributor: Joel Pedraza <joel@joelpedraza.com>
+# Contributor: Jakub Schmidtke <sjakub-at-gmail-dot-com>
+
+_rev=r01
+_sdkint=28
+_sdkver=9.0.0
+pkgname="android-sources-${_sdkint}"
+pkgver="${_sdkver}_${_rev}"
+pkgrel=1
+pkgdesc="Android SDK Sources, API-${_sdkint}"
+arch=(any)
+url="https://developer.android.com/studio/index.html"
+license=('custom')
+conflicts=("android-sources=${_sdkint}")
+options=('!strip')
+source=("https://dl.google.com/android/repository/sources-${_sdkint}_${_rev}.zip")
+sha256sums=('7c05aecdc5b56a8d30837ff80885e95736e455aef4d442a5f5f39fe9652250f0')
+
+
+package() {
+ mkdir -p "${pkgdir}/opt/android-sdk/sources/"
+ cp -dpr --no-preserve=ownership "${srcdir}/src" "${pkgdir}/opt/android-sdk/sources/android-${_sdkint}"
+ chmod -R ugo+rX "${pkgdir}/opt"
+} \ No newline at end of file