summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBatuhan Başerdem2020-04-04 10:22:10 -0400
committerBatuhan Başerdem2020-04-04 10:22:10 -0400
commitfcd8ac9c99c8cc491ae9c9d5e5906127b1d9f2c7 (patch)
tree8728d908cd8ef566764f9dfbdd86162ed65db9c1
downloadaur-fcd8ac9c99c8cc491ae9c9d5e5906127b1d9f2c7.tar.gz
Initialized repo
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b3b60e8cbf6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = powerline-console-fonts-git
+ pkgdesc = Various powerline patched fonts for the text console
+ pkgver = r104.ge80e3eb
+ pkgrel = 1
+ url = https://github.com/powerline/fonts
+ arch = any
+ license = MIT
+ makedepends = git
+ provides = powerline-console-fonts
+ conflicts = powerline-console-fonts
+ source = git+https://github.com/powerline/fonts
+ sha512sums = SKIP
+
+pkgname = powerline-console-fonts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e6045b6edc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Batuhan Baserdem <last.first@gmail.com>
+# Based on powerline-console-fonts by; Simon Doppler <dopsi[at]dopsi[dot]ch>
+
+_reponame='fonts'
+pkgname=powerline-console-fonts-git
+pkgver='r104.ge80e3eb'
+pkgrel=1
+pkgdesc="Various powerline patched fonts for the text console"
+arch=('any')
+url="https://github.com/powerline/${_reponame}"
+license=('MIT')
+source=("git+${url}")
+sha512sums=('SKIP')
+makedepends=('git')
+provides=('powerline-console-fonts')
+conflicts=('powerline-console-fonts')
+
+pkgver() {
+ git describe --long --tags | \
+ sed 's|\([0-9]\+.[0-9]\+.[0-9]\+.\)\([^-]*-g\)|r\2|;s|-|.|g;s|^v||g'
+}
+
+package() {
+ # Installing psf version fonts
+ for fdir in "$(find "${srcdir}/${_reponame}" -iname '*psf')" ; do
+ bdir="$(dirname "${fdir}")"
+ name="$(basename "${bdir}" | tr '[:upper:]' '[:lower:]')"
+ msg2 "Found ${name}, packaging..."
+ # Install the license file
+ install -Dm 664 "$(find "${bdir}" -iname '*license*' | head -n 1)" \
+ "${pkgdir}/usr/share/licenses/${name}-consolefont"
+ # Install the fonts
+ find "${fdir}" -iname '*.psf*' -print0 |
+ xargs -0 install -D -t "${pkgdir}/usr/share/kbd/consolefonts"
+ done
+}