summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2024-03-06 09:12:23 +0100
committerJoan Figueras2024-03-06 09:12:23 +0100
commitfd0250c3026d5d99521385e811864c0404aabd8c (patch)
tree7a1a64a9d293130412db0b5940fec9407d4de6ff
parentbd9a7bc6af267cc86a06f4f43566ce4626cec9fe (diff)
downloadaur-fd0250c3026d5d99521385e811864c0404aabd8c.tar.gz
Some minor changes from arch kernel package
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 648b5eb1e744..48b416ab2cb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -82,7 +82,6 @@ pkgrel=${xanmod}
pkgdesc='Linux Xanmod - Stable Mainline [MAIN]'
url="http://www.xanmod.org/"
arch=(x86_64)
-
license=(GPL2)
makedepends=(
bc
@@ -222,7 +221,9 @@ prepare() {
fi
fi
+ msg2 "make ${_compiler_flags} olddefconfig"
make ${_compiler_flags} olddefconfig
+ #diff -u CONFIGS/xanmod/gcc/${_config} .config || :
make -s kernelrelease > version
msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
@@ -238,6 +239,7 @@ prepare() {
build() {
cd linux-${_major}
make ${_compiler_flags} all
+ make -C tools/bpf/bpftool vmlinux.h feature-clang-bpf-co-re=1
}
_package() {
@@ -290,7 +292,7 @@ _package-headers() {
msg2 "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
- localversion.* version vmlinux
+ localversion.* version vmlinux tools/bpf/bpftool/vmlinux.h
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
@@ -299,7 +301,7 @@ _package-headers() {
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# required when DEBUG_INFO_BTF_MODULES is enabled
- if [ -f "tools/bpf/resolve_btfids/resolve_btfids" ]; then install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids ; fi
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
msg2 "Installing headers..."
cp -t "$builddir" -a include