summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2022-04-24 06:19:04 -0600
committerBrian Bidulock2022-04-24 06:19:04 -0600
commitfd0ab340cf04819beb39fb223caed250ac439169 (patch)
tree0b64cd2b905a519fb3e44b8ffff1d39c9ae3f5a8
parent76206ef5870a8d7dac70893b30a4050487351dc4 (diff)
downloadaur-fd0ab340cf04819beb39fb223caed250ac439169.tar.gz
fix package
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--ha-glue.install4
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8796fb50940..588dd4f5b528 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = ha-glue
pkgdesc = A set of libraries, tools and utilities suitable for the Heartbeat/Pacemaker cluster stack.
pkgver = 1.0.12
- pkgrel = 5
+ pkgrel = 6
url = http://linux-ha.org/wiki/Cluster_Glue
- install = ha-glue.install
arch = i686
arch = x86_64
license = GPL
@@ -18,9 +17,6 @@ pkgbase = ha-glue
options = !libtool
options = docs
source = http://hg.linux-ha.org/glue/archive/glue-1.0.12.tar.bz2
- source = ha-glue.install
md5sums = ec620466d6f23affa3b074b72bca7870
- md5sums = b3e3b0e1f6d0e1e6748c1d463d9f3bf4
pkgname = ha-glue
-
diff --git a/PKGBUILD b/PKGBUILD
index 7c3f8ce6653c..71bf33e30c11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ha-glue
pkgver=1.0.12
-pkgrel=5
+pkgrel=6
pkgdesc="A set of libraries, tools and utilities suitable for the Heartbeat/Pacemaker cluster stack."
arch=('i686' 'x86_64')
url="http://linux-ha.org/wiki/Cluster_Glue"
@@ -15,11 +15,8 @@ depends=('net-snmp'
'curl'
'glib2'
'asciidoc')
-source=("http://hg.linux-ha.org/glue/archive/glue-${pkgver}.tar.bz2"
- "ha-glue.install")
-md5sums=('ec620466d6f23affa3b074b72bca7870'
- 'b3e3b0e1f6d0e1e6748c1d463d9f3bf4')
-install='ha-glue.install'
+source=("http://hg.linux-ha.org/glue/archive/glue-${pkgver}.tar.bz2")
+md5sums=('ec620466d6f23affa3b074b72bca7870')
options=('!libtool' 'docs')
build() {
@@ -58,6 +55,8 @@ build() {
--with-daemon-group=${_CLUSTER_GROUP} \
--enable-fatal-warnings=no
#sed -i 's/lib64\ //g' configure.ac
+ # Fight unused direct deps
+ sed -i -e "s| -shared | $LDFLAGS\0 |g" -e "s| if test \"\$export_dynamic\" = yes && test -n \"\$export_dynamic_flag_spec\"; then| func_append compile_command \" $LDFLAGS\"\n func_append finalize_command \" $LDFLAGS\"\n\0|" libtool
make
}
@@ -76,5 +75,10 @@ package() {
sed -i 's:/usr/bin/env python$:/usr/bin/env python2:g' ${py}
done
#end python path correction
+ install -Dm644 /dev/null "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ cat>"$pkgdir/usr/lib/sysusers.d/$pkgname.conf"<<-EOF
+ g haclient 189
+ u hacluster 189:189 "cluster user" /var/lib/heartbeat/cores/hacluster /sbin/nologin
+ EOF
}
diff --git a/ha-glue.install b/ha-glue.install
index dbc46f1e5f64..9f740a645c15 100644
--- a/ha-glue.install
+++ b/ha-glue.install
@@ -1,7 +1,7 @@
_CLUSTER_USER=hacluster
_CLUSTER_GROUP=haclient
-_DGID=666
-_DUID=666
+_DGID=189
+_DUID=189
pre_install() {