summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Sztandera2016-05-17 16:24:16 +0200
committerJakub Sztandera2016-05-17 16:24:16 +0200
commitfd4f6a10978e40e469c692834c799967c15e338c (patch)
tree1beef121bd49490162805dcfd2f1ef409fab83f7
parentd00e06ff6d0e5cb5841fad2c3ba2ac024711ec2b (diff)
downloadaur-fd4f6a10978e40e469c692834c799967c15e338c.tar.gz
Add ipfs.service, make package rebuildable
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--ipfs.service9
3 files changed, 20 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f4c1d016929..f493b57f9867 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue May 17 09:38:48 UTC 2016
+# Tue May 17 14:23:49 UTC 2016
pkgbase = go-ipfs-git
pkgdesc = global versioned p2p merkledag file system
pkgver = 0.4.1.r165.gf36671d
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ipfs/go-ipfs
arch = i686
arch = x86_64
@@ -16,7 +16,9 @@ pkgbase = go-ipfs-git
provides = go-ipfs
conflicts = go-ipfs
source = git+https://github.com/ipfs/go-ipfs.git
- md5sums = SKIP
+ source = ipfs.service
+ sha512sums = SKIP
+ sha512sums = 1a6bc7fffc3c3640cda3f33c107424edd698c62bd8509731856b8827ea18be1a1845ef0d5ca15325d48d7d871a78daacc011ff9eacea926bc35899850990c1c6
pkgname = go-ipfs-git
diff --git a/PKGBUILD b/PKGBUILD
index 0e31e1912816..73077e6aaf04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=go-ipfs
pkgname=$_pkgname-git
pkgver=0.4.1.r165.gf36671d
-pkgrel=1
+pkgrel=2
pkgdesc='global versioned p2p merkledag file system'
url="https://github.com/ipfs/$_pkgname"
arch=('i686' 'x86_64' 'armv7h')
@@ -15,8 +15,9 @@ optdepends=('fuse: for mounting/advanced use'
'bash-completion: bash completion support')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+${url}.git")
-md5sums=('SKIP')
+source=("git+${url}.git" "ipfs.service")
+sha512sums=('SKIP'
+ '1a6bc7fffc3c3640cda3f33c107424edd698c62bd8509731856b8827ea18be1a1845ef0d5ca15325d48d7d871a78daacc011ff9eacea926bc35899850990c1c6')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -25,7 +26,7 @@ pkgver() {
prepare() {
mkdir -p "$srcdir"/src/github.com/ipfs
- ln -s "$srcdir/$_pkgname" "$srcdir"/src/github.com/ipfs/go-ipfs
+ ln -sf "$srcdir/$_pkgname" "$srcdir"/src/github.com/ipfs/go-ipfs
}
build() {
@@ -49,6 +50,7 @@ package() {
msg2 'Packaging auxiliary files...'
cd "$_pkgname"
+ install -Dm 644 ../ipfs.service "$pkgdir/usr/lib/systemd/user/ipfs.service"
install -Dm 644 misc/completion/ipfs-completion.bash "${pkgdir}/usr/share/bash-completions/completions/ipfs"
install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
install -Dm 644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
diff --git a/ipfs.service b/ipfs.service
new file mode 100644
index 000000000000..257f2016c15f
--- /dev/null
+++ b/ipfs.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=InterPlanetary File System (IPFS) daemon
+
+[Service]
+ExecStart=/usr/bin/ipfs daemon
+Restart=on-failure
+
+[Install]
+WantedBy=default.target