summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenningstone2018-04-11 21:16:42 +0200
committerHenningstone2018-04-11 21:16:42 +0200
commitfd76639059f8e2f10b1efb19aba2c2d6573743ec (patch)
tree609bd5135addaedcc28189c77a002832d1aa7779
parent8d7404239a91392d3213daebf92fa691fa33461d (diff)
downloadaur-fd76639059f8e2f10b1efb19aba2c2d6573743ec.tar.gz
Fixed namcap warnings
-rw-r--r--.SRCINFO7
-rw-r--r--0001-Don-t-link-unnecessary-libs.patch42
-rw-r--r--PKGBUILD22
-rw-r--r--allthehaxx.install (renamed from allthehaxx)0
4 files changed, 58 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 882ed3da9550..a38c42c95b8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,26 +3,27 @@ pkgbase = allthehaxx
pkgver = 0.36
pkgrel = 1
url = https://allthehaxx.github.io
- install = allthehaxx
+ install = allthehaxx.install
arch = x86_64
license = custom
makedepends = bam
makedepends = imagemagick
makedepends = gendesk
makedepends = python
- depends = alsa-lib
depends = sdl2
+ depends = glu
depends = freetype2
depends = opusfile
depends = curl
- depends = wavpack
optdepends = ddnet-skins: more skins for your tee (provided by DDNet)
optdepends = ddnet-maps-git: have all DDNet maps available offline
backup = etc/allthehaxx/storage.cfg
backup = etc/allthehaxx/mapdbs.cfg
backup = etc/allthehaxx/skindbs.cfg
source = https://media.githubusercontent.com/media/AllTheHaxx/stuffility/master/releases/AllTheHaxx-0.36.tar.gz
+ source = 0001-Don-t-link-unnecessary-libs.patch
sha256sums = 707d7d5b5861c918a52c5fc472e20c65dc21bac2f4294fda3945aba43c2494b5
+ sha256sums = 4f106ea29e22bc586b3a5a3bd4c1963723c43f5fceb3075db48ead74a7617354
pkgname = allthehaxx
diff --git a/0001-Don-t-link-unnecessary-libs.patch b/0001-Don-t-link-unnecessary-libs.patch
new file mode 100644
index 000000000000..d28ef8bc77dc
--- /dev/null
+++ b/0001-Don-t-link-unnecessary-libs.patch
@@ -0,0 +1,42 @@
+From de68de168f36aa677e5cf6559209681328e4fafc Mon Sep 17 00:00:00 2001
+From: Henningstone <Henningstone@users.noreply.github.com>
+Date: Wed, 11 Apr 2018 20:22:59 +0200
+Subject: [PATCH] Don't link unnecessary libs
+
+---
+ bam.lua | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/bam.lua b/bam.lua
+index 594e44836..3363d698e 100644
+--- a/bam.lua
++++ b/bam.lua
+@@ -388,8 +388,6 @@ function build(settings)
+ client_settings.link.libs:Add("X11")
+ client_settings.link.libs:Add("GL")
+ client_settings.link.libs:Add("GLU")
+- client_settings.link.libs:Add("ssl")
+- client_settings.link.libs:Add("crypto")
+ end
+
+ elseif family == "windows" then
+@@ -422,7 +420,6 @@ function build(settings)
+ config.opusfile:Apply(client_settings)
+
+ if family == "unix" and (platform == "macosx" or platform == "linux") then
+- engine_settings.link.libs:Add("dl")
+ server_settings.link.libs:Add("dl")
+ client_settings.link.libs:Add("dl")
+ launcher_settings.link.libs:Add("dl")
+@@ -459,8 +456,6 @@ function build(settings)
+ end
+
+ -- build tools (TODO: fix this so we don't get double _d_d stuff)
+- tools_settings.link.libs:Add("ssl")
+- tools_settings.link.libs:Add("crypto")
+ tools_src = Collect("src/tools/*.cpp", "src/tools/*.c")
+
+ tools = {}
+--
+2.16.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 743aa03bc824..ec9f37e34703 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=allthehaxx
pkgver=0.36
-pkgrel=1
+pkgrel=2
pkgdesc="AllTernative Teeworlds Client"
arch=('x86_64')
url="https://allthehaxx.github.io"
license=('custom')
-depends=('alsa-lib' 'sdl2' 'freetype2' 'opusfile' 'curl' 'wavpack')
+depends=('sdl2' 'glu' 'freetype2' 'opusfile' 'curl')
makedepends=('bam' 'imagemagick' 'gendesk' 'python')
optdepends=('ddnet-skins: more skins for your tee (provided by DDNet)'
'ddnet-maps-git: have all DDNet maps available offline')
@@ -17,25 +17,29 @@ backup=('etc/allthehaxx/storage.cfg'
'etc/allthehaxx/mapdbs.cfg'
'etc/allthehaxx/skindbs.cfg')
#options=('!strip' 'debug') # uncomment this if you want to gdb AllTheHaxx
-install=allthehaxx
-source=("https://media.githubusercontent.com/media/AllTheHaxx/stuffility/master/releases/AllTheHaxx-$pkgver.tar.gz")
-sha256sums=('707d7d5b5861c918a52c5fc472e20c65dc21bac2f4294fda3945aba43c2494b5')
+install=allthehaxx.install
+source=("https://media.githubusercontent.com/media/AllTheHaxx/stuffility/master/releases/AllTheHaxx-$pkgver.tar.gz"
+ '0001-Don-t-link-unnecessary-libs.patch')
+sha256sums=('707d7d5b5861c918a52c5fc472e20c65dc21bac2f4294fda3945aba43c2494b5'
+ '4f106ea29e22bc586b3a5a3bd4c1963723c43f5fceb3075db48ead74a7617354')
prepare() {
# Client
- convert "AllTheHaxx-$pkgver/other/icons/AllTheHaxx.ico" AllTheHaxx.png
+ cd "$srcdir/AllTheHaxx-$pkgver/"
+ convert "other/icons/AllTheHaxx.ico" AllTheHaxx.png
+ patch -p1 -i "$srcdir/0001-Don-t-link-unnecessary-libs.patch"
}
build() {
- cd "AllTheHaxx-$pkgver/"
+ cd "$srcdir/AllTheHaxx-$pkgver/"
bam config installation_root="/"
bam client_release
bam tools_release
}
package() {
- cd "AllTheHaxx-$pkgver/"
+ cd "$srcdir/AllTheHaxx-$pkgver/"
# Install AllTheHaxx client binaries
install -d -m755 "$pkgdir/usr/bin/"
install -m755 AllTheHaxx "$pkgdir/usr/bin/"
@@ -75,8 +79,6 @@ package() {
install -Dm644 other/AllTheHaxx.desktop "$pkgdir/usr/share/applications/allthehaxx.desktop"
install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/license.txt"
- cd ..
-
# Install icon files
install -Dm644 AllTheHaxx-4.png "$pkgdir/usr/share/pixmaps/AllTheHaxx.png"
}
diff --git a/allthehaxx b/allthehaxx.install
index 20f8fc708210..20f8fc708210 100644
--- a/allthehaxx
+++ b/allthehaxx.install