summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Minges2015-07-06 22:30:40 +0200
committerAlexander Minges2015-07-06 22:30:40 +0200
commitfda14d56c555dc3280e5d219b1b1b813a37f4858 (patch)
tree2411a8d22e0999d9b8482227e0579e2e4cde56be
downloadaur-fda14d56c555dc3280e5d219b1b1b813a37f4858.tar.gz
Initital import
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE16
-rw-r--r--PKGBUILD34
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f1d6b148335
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tmtools
+ pkgdesc = TM-align is a computer algorithm for protein structure alignment using dynamic programming and TM-score rotation matrix
+ pkgver = 20140601
+ pkgrel = 1
+ url = http://zhanglab.ccmb.med.umich.edu/TM-align/
+ arch = x86_64
+ arch = i686
+ license = custom
+ makedepends = gcc-fortran
+ source = http://zhanglab.ccmb.med.umich.edu/TM-align/TMtools20140601.tar.gz
+ source = LICENSE
+ sha256sums = 5032f7ab1824c8b2191b4a3667e1405feb6ccf7c900f57632aa506fff8ec1bf5
+ sha256sums = 6702b261d43b8ce84af0aecabb2ff3c8a4187204f65b0b60c8d5fb5b9f24961b
+
+pkgname = tmtools
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ffa0230491f7
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,16 @@
+This program is to identify the best alignment of two protein
+structures that gives the highest TM-score. Input structures must
+be in the PDB format. By default, TM-score is normalized by the
+second protein. Users can obtain a brief instruction by simply
+running the program without arguments. For comments/suggestions,
+please contact email: zhng@umich.edu.
+
+Reference to cite:
+Yang Zhang, Jeffrey Skolnick, Nucl. Acid Res. 2005 33: 2303-9
+
+Permission to use, copy, modify, and distribute this program for
+any purpose, with or without fee, is hereby granted, provided that
+the notices on the head, the reference information, and this
+copyright notice appear in all copies or substantial portions of
+the Software. It is provided "as is" without express or implied
+warranty. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecd9c0993af1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Athemis <alexander.minges[at]googlemail[dot]com>
+pkgname=tmtools
+_pkgname=TMtools
+pkgver=20140601
+pkgrel=1
+pkgdesc="TM-align is a computer algorithm for protein structure alignment using dynamic programming and TM-score rotation matrix"
+url="http://zhanglab.ccmb.med.umich.edu/TM-align/"
+arch=('x86_64' 'i686')
+license=('custom')
+makedepends=('gcc-fortran')
+source=("http://zhanglab.ccmb.med.umich.edu/TM-align/${_pkgname}${pkgver}.tar.gz"
+ "LICENSE")
+
+sha256sums=('5032f7ab1824c8b2191b4a3667e1405feb6ccf7c900f57632aa506fff8ec1bf5'
+ '6702b261d43b8ce84af0aecabb2ff3c8a4187204f65b0b60c8d5fb5b9f24961b')
+
+build() {
+ cd "${srcdir}"
+ rm TMalign
+ rm TMscore
+ gfortran -march=native -O3 -pipe -ffast-math -lm -o TMalign TMalign.f
+ gfortran -march=native -O3 -pipe -ffast-math -lm -o TMscore TMscore.f
+}
+
+package() {
+ cd "${srcdir}"
+ install -d ${pkgdir}/usr/bin
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -Dm755 TMalign ${pkgdir}/usr/bin
+ install -Dm755 TMscore ${pkgdir}/usr/bin
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
+}
+
+# vim:set ts=2 sw=2 et: