summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Nielsen2015-06-27 19:51:42 +1000
committerAdam Nielsen2015-06-27 19:51:42 +1000
commitfdac2b8c6ad59e6c86ae52a258c506f8dd64866f (patch)
treeab26425100fed1224c9f635227922553efad3000
downloadaur-fdac2b8c6ad59e6c86ae52a258c506f8dd64866f.tar.gz
Import to AUR4
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD74
-rw-r--r--dosbox.pngbin0 -> 4691 bytes
-rw-r--r--gcc46.patch12
4 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..738baf495bd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = dosbox-debug
+ pkgdesc = Emulator with builtin DOS for running DOS games (includes debugger for DOS apps)
+ pkgver = 0.74
+ pkgrel = 2
+ url = http://dosbox.sourceforge.net/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = libgl
+ makedepends = gendesk>=0.5.3
+ depends = sdl_net
+ depends = zlib
+ depends = sdl_sound
+ depends = libgl
+ depends = libpng
+ depends = alsa-lib
+ depends = gcc-libs
+ depends = glu
+ provides = dosbox
+ conflicts = dosbox
+ source = http://downloads.sourceforge.net/dosbox/dosbox-0.74.tar.gz
+ source = dosbox.png
+ source = gcc46.patch
+ md5sums = b9b240fa87104421962d14eee71351e8
+ md5sums = 2aac25fc06979e375953fcc36824dc5e
+ md5sums = 3fba2e3c7c43290319b2928f40ed30e5
+
+pkgname = dosbox-debug
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..660aa38749e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: Adam Nielsen <malvineous@shikadi.net>
+# Contributor: Jaroslav Lichtblau
+# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
+# Contributor: James Rayner <james@archlinux.org>
+# Contributor: Ben <ben@benmazer.net>
+
+pkgname=dosbox-debug
+srcname=dosbox
+pkgver=0.74
+pkgrel=2
+pkgdesc='Emulator with builtin DOS for running DOS games (includes debugger for DOS apps)'
+arch=('x86_64' 'i686')
+url='http://dosbox.sourceforge.net/'
+license=('GPL')
+depends=('sdl_net' 'zlib' 'sdl_sound' 'libgl' 'libpng' 'alsa-lib' 'gcc-libs' 'glu')
+# libgl can be provided by mesa-libgl or the nVidia closed-source driver
+makedepends=('libgl' 'gendesk>=0.5.3')
+provides=('dosbox')
+conflicts=('dosbox')
+source=("http://downloads.sourceforge.net/$srcname/$srcname-$pkgver.tar.gz"
+ 'dosbox.png'
+ 'gcc46.patch')
+md5sums=('b9b240fa87104421962d14eee71351e8'
+ '2aac25fc06979e375953fcc36824dc5e'
+ '3fba2e3c7c43290319b2928f40ed30e5')
+
+prepare() {
+ cd "$srcdir"
+
+ gendesk --pkgname "$srcname" --pkgdesc "$pkgdesc" --exec "$srcname" --name "DOSBox"
+ gendesk --pkgname "$pkgname" --pkgdesc "$pkgdesc" --terminal=true --name "DOSBox (debug)"
+}
+
+build() {
+ cd "$srcdir/$srcname-$pkgver"
+
+ patch -Np1 -i "$srcdir/gcc46.patch"
+ sed -i 's/png_check_sig/png_sig_cmp/' configure
+
+ # Compile alternate version with built-in debugger enabled
+ ./configure --prefix=/usr \
+ --enable-debug \
+ --sysconfdir=/etc/dosbox
+ make
+ mv src/dosbox src/dosbox-debug
+
+ # Compile original version without DOS debugger
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/dosbox
+ make
+}
+
+package() {
+ cd "$srcdir/$srcname-$pkgver"
+
+ # Install everything including the non-debug binary
+ make DESTDIR="$pkgdir" install
+
+ # Install the debug binary
+ install -Dm755 "src/$pkgname" "$pkgdir/usr/bin/$pkgname"
+
+ # install docs, make does not install them
+ install -Dm644 README "$pkgdir"/usr/share/doc/$srcname/README
+ install -Dm644 docs/README.video "$pkgdir"/usr/share/doc/$srcname/README.video
+
+ install -Dm644 "$srcdir/$srcname.png" \
+ "$pkgdir/usr/share/pixmaps/$srcname.png"
+ install -Dm644 "$srcdir/$srcname.desktop" \
+ "$pkgdir/usr/share/applications/$srcname.desktop"
+ install -Dm644 "$srcdir/$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/dosbox.png b/dosbox.png
new file mode 100644
index 000000000000..b8a9179864a8
--- /dev/null
+++ b/dosbox.png
Binary files differ
diff --git a/gcc46.patch b/gcc46.patch
new file mode 100644
index 000000000000..eae9ae63e611
--- /dev/null
+++ b/gcc46.patch
@@ -0,0 +1,12 @@
+diff -aur dosbox-0.74/include/dos_inc.h dosbox-0.74.new//include/dos_inc.h
+--- dosbox-0.74/include/dos_inc.h 2010-05-10 17:43:54.000000000 +0000
++++ dosbox-0.74.new//include/dos_inc.h 2011-06-17 20:42:43.982548979 +0000
+@@ -28,6 +28,8 @@
+ #include "mem.h"
+ #endif
+
++#include <stddef.h> //for offsetof
++
+ #ifdef _MSC_VER
+ #pragma pack (1)
+ #endif