summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorToolybird2023-03-29 07:26:57 +1100
committerToolybird2023-03-29 07:26:57 +1100
commitfdaf9acf99112cb26fa1c1b36c5535cb38719063 (patch)
tree600a169f4a004ebe27fec8b49005c5c6b2b9ac8f
parentf05449e380fd17e3206e8d9dbd01e8cb4fbc1188 (diff)
downloadaur-fdaf9acf99112cb26fa1c1b36c5535cb38719063.tar.gz
Upgrade to 1.0.90 and apply fix
- add sed to dietlibc headers to fix <cpuid.h> compile
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dcb978b6099..abc476b11061 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ventoy
pkgdesc = A new bootable USB solution
- pkgver = 1.0.89
+ pkgver = 1.0.90
pkgrel = 1
url = https://www.ventoy.net/
arch = x86_64
@@ -42,7 +42,7 @@ pkgbase = ventoy
noextract = cryptsetup-1.7.5.tar.xz
noextract = wimboot-2.7.3.tar.gz
options = !buildflags
- source = ventoy-1.0.89.tar.gz::https://github.com/ventoy/Ventoy/archive/refs/tags/v1.0.89.tar.gz
+ source = ventoy-1.0.90.tar.gz::https://github.com/ventoy/Ventoy/archive/refs/tags/v1.0.90.tar.gz
source = https://ftp.gnu.org/gnu/grub/grub-2.04.tar.xz
source = ventoy-grub-fix-build-with-binutils-2.36.patch::https://git.savannah.gnu.org/cgit/grub.git/patch/configure.ac?id=b9827513
source = git+https://github.com/ipxe/ipxe.git#commit=3fe683e
@@ -63,7 +63,7 @@ pkgbase = ventoy
source = https://busybox.net/downloads/busybox-1.32.0.tar.bz2
source = https://mirrors.edge.kernel.org/pub/linux/utils/cryptsetup/v1.7/cryptsetup-1.7.5.tar.xz
source = wimboot-2.7.3.tar.gz::https://github.com/ipxe/wimboot/archive/v2.7.3.tar.gz
- sha256sums = e5f82113f7423a8c82fe52e3ca7de4dc3cabf6665e9b540476e723f6e6886fc5
+ sha256sums = edc9cebbce9122410be358c36e0954a25ea19ea7e647bbaa5467f057a028eb5b
sha256sums = e5292496995ad42dabe843a0192cf2a2c502e7ffcc7479398232b10a472df77d
sha256sums = db2a9018392a3984d1e1e649bde0ffc19c90fa4d96b9fd2d4caaf9c1ca2af68b
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bc4a71c1fd43..d6e336c7a04c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,7 +33,7 @@
# have been modified.
pkgname=ventoy
-pkgver=1.0.89
+pkgver=1.0.90
_grub_ver=2.04 # (Jul 2019)
#_unifont_ver=15.0.01 # FIXME see NOTE below
_ipxe_ver=3fe683e # (Sep 29 2019)
@@ -127,7 +127,7 @@ noextract=(
cryptsetup-"$_crypt_ver".tar.xz
wimboot-"$_wimboot_ver".tar.gz
)
-sha256sums=('e5f82113f7423a8c82fe52e3ca7de4dc3cabf6665e9b540476e723f6e6886fc5'
+sha256sums=('edc9cebbce9122410be358c36e0954a25ea19ea7e647bbaa5467f057a028eb5b'
'e5292496995ad42dabe843a0192cf2a2c502e7ffcc7479398232b10a472df77d'
'db2a9018392a3984d1e1e649bde0ffc19c90fa4d96b9fd2d4caaf9c1ca2af68b'
'SKIP'
@@ -236,6 +236,9 @@ prepare() {
# Fix from Debian. Avoid errors when compiling apps against recent kernel headers. FIXME
patch -Np1 -i "$srcdir"/dietlibc-headers-fix.patch
+
+ # <cpuid.h> compile fix
+ sed -i 's/__leaf/__LEAF/' include/sys/cdefs.h
)
(
@@ -364,10 +367,10 @@ _build_vtoytool() (
# Refer "VtoyTool/build.sh"
cd Ventoy-$pkgver/VtoyTool
- "$srcdir"/dietlibc-$_diet_ver/bin-x86_64/diet -Os gcc -D_FILE_OFFSET_BITS=64 ./*.c BabyISO/*.c \
+ "$srcdir"/dietlibc-$_diet_ver/bin-x86_64/diet -Os gcc -DVTOY_X86_64 -D_FILE_OFFSET_BITS=64 ./*.c BabyISO/*.c \
-IBabyISO -Wall -DBUILD_VTOY_TOOL -DUSE_DIET_C -o vtoytool_64
- "$srcdir"/dietlibc-$_diet_ver/bin-i386/diet -Os gcc -D_FILE_OFFSET_BITS=64 -m32 ./*.c BabyISO/*.c \
+ "$srcdir"/dietlibc-$_diet_ver/bin-i386/diet -Os gcc -DVTOY_I386 -D_FILE_OFFSET_BITS=64 -m32 ./*.c BabyISO/*.c \
-IBabyISO -Wall -DBUILD_VTOY_TOOL -DUSE_DIET_C -o vtoytool_32
strip --strip-all vtoytool_{64,32}