summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2024-04-28 17:45:14 +0200
committerThomas Weißschuh2024-04-28 17:45:14 +0200
commitfdb788afb37ddb1c42f01493032798592500a1ed (patch)
treee4d25e7a0ea808ac2d4f698d4da9ccf08c7b407b
parentbfa0135010fb64e8135d25fe7bb3e7e3669c73ed (diff)
downloadaur-fdb788afb37ddb1c42f01493032798592500a1ed.tar.gz
1.38.1
-rw-r--r--0001-tests-gcs-skip-tests-without-google-cloud-module.patch34
-rw-r--r--PKGBUILD10
2 files changed, 41 insertions, 3 deletions
diff --git a/0001-tests-gcs-skip-tests-without-google-cloud-module.patch b/0001-tests-gcs-skip-tests-without-google-cloud-module.patch
new file mode 100644
index 000000000000..57edb1d76aee
--- /dev/null
+++ b/0001-tests-gcs-skip-tests-without-google-cloud-module.patch
@@ -0,0 +1,34 @@
+From e5e1bb8c1320946bcf97cb5ee025b30b52c1fa94 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thomas=20Wei=C3=9Fschuh?= <thomas@t-8ch.de>
+Date: Sun, 28 Apr 2024 17:32:37 +0200
+Subject: [PATCH nbdkit] tests: gcs: skip tests without google cloud module
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+To: libguestfs@redhat.com, "Richard W.M. Jones" <rjones@redhat.com>
+
+The gcs plugin uses the google cloud module and can't work without it.
+Skip the test if the module is unavailable.
+
+Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
+---
+ tests/test-gcs.sh | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tests/test-gcs.sh b/tests/test-gcs.sh
+index ed823377dc5a..9b165e8159be 100755
+--- a/tests/test-gcs.sh
++++ b/tests/test-gcs.sh
+@@ -40,6 +40,7 @@ requires $PYTHON --version
+ requires_nbdcopy
+ requires_plugin python
+ skip_if_valgrind "because Python code leaks memory"
++requires $PYTHON -c 'import google.cloud'
+
+ # Skip this test if the real google-cloud-storage module is installed,
+ # since that module abuses pth files to insert itself into the module
+
+base-commit: ffa62d30fe6dcd29ae8e20df5c86d48505550614
+--
+2.44.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 8ae586aef061..8dd9ae4689cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thomas Weißschuh <thomas t-8ch de>
pkgname=nbdkit
-pkgver=1.36.4
+pkgver=1.38.1
pkgrel=1
pkgdesc="NBD server toolkit"
arch=('x86_64')
@@ -35,6 +35,7 @@ source=(
"http://download.libguestfs.org/nbdkit/${_dldir}-stable/nbdkit-${pkgver}.tar.gz"
"http://download.libguestfs.org/nbdkit/${_dldir}-stable/nbdkit-${pkgver}.tar.gz.sig"
broken-file.patch
+ 0001-tests-gcs-skip-tests-without-google-cloud-module.patch
)
prepare() {
@@ -42,6 +43,8 @@ prepare() {
# https://github.com/file/file/pull/137
patch -p1 < "${srcdir}/broken-file.patch"
+ patch -p1 < "${srcdir}/0001-tests-gcs-skip-tests-without-google-cloud-module.patch"
+
}
build() {
@@ -69,6 +72,7 @@ check() {
make check
}
-sha256sums=('70720bc67a2404d4e50ca75afe49e07352686327f428f4c7706a9b55229b0e8e'
+sha256sums=('c6ee1d73fe033fff1168b61f64e03d796a0dfd4d5e81537069dd174cecdc78b3'
'SKIP'
- '7150a8b5849ef48c7e60a93cd461ee658df02a4184c182df305b2cd16371473e')
+ '7150a8b5849ef48c7e60a93cd461ee658df02a4184c182df305b2cd16371473e'
+ 'e76cb0a6dfdd444689f957d56b0a5b07178f015d909418e1d859d04aaaf466e2')