summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2023-02-11 11:03:50 -1000
committerGaetan Bisson2023-02-11 11:03:50 -1000
commitfdd53105db8352f066d369158154e34bf4519911 (patch)
tree91292e2dbde0a9394fe62169b9fdb7cd7e0b832a
parentfa2223c099e80260d1fddb2a4c0c9623b686a37f (diff)
parente8f25348c23f3256094944ebbfe956453b7c1490 (diff)
downloadaur-fdd53105db8352f066d369158154e34bf4519911.tar.gz
Merge branch 'master' of ssh://aur/mupdf-git
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--output-jpeg.patch37
3 files changed, 44 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 310fa70fb47f..0789d7bbfba3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mupdf-git
pkgdesc = Lightweight PDF, XPS, and E-book viewer
- pkgver = 20221220.a76b4ed0d
+ pkgver = 20230207.1ca88ef11
pkgrel = 1
url = https://mupdf.com/
arch = x86_64
@@ -27,11 +27,13 @@ pkgbase = mupdf-git
source = git://git.ghostscript.com/thirdparty-extract.git
source = git://git.ghostscript.com/thirdparty-freeglut.git
source = git://git.ghostscript.com/thirdparty-lcms2.git#branch=lcms2mt
+ source = output-jpeg.patch
source = desktop
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = bf9b2349d4adda7118bc32005ade1d52c545dba980765443f2aeba198c2f85df
sha256sums = 3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd
pkgname = mupdf-git
diff --git a/PKGBUILD b/PKGBUILD
index e00f9993dddb..0ea2b9372960 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mupdf-git
_pkgname=mupdf
-pkgver=20221220.a76b4ed0d
+pkgver=20230207.1ca88ef11
pkgrel=1
pkgdesc='Lightweight PDF, XPS, and E-book viewer'
arch=('x86_64' 'armv7h' 'aarch64')
@@ -16,11 +16,13 @@ source=('git://git.ghostscript.com/mupdf.git'
'git://git.ghostscript.com/thirdparty-extract.git'
'git://git.ghostscript.com/thirdparty-freeglut.git'
'git://git.ghostscript.com/thirdparty-lcms2.git#branch=lcms2mt'
+ 'output-jpeg.patch'
'desktop')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'bf9b2349d4adda7118bc32005ade1d52c545dba980765443f2aeba198c2f85df'
'3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd')
conflicts=("${_pkgname}"{,-gl,-tools})
@@ -33,6 +35,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
+ patch -p1 -i ../output-jpeg.patch source/fitz/output-jpeg.c
for lib in extract freeglut lcms2; do
rm -fr thirdparty/$lib
cp -a ../thirdparty-$lib thirdparty/$lib
diff --git a/output-jpeg.patch b/output-jpeg.patch
new file mode 100644
index 000000000000..03006b2a7da7
--- /dev/null
+++ b/output-jpeg.patch
@@ -0,0 +1,37 @@
+--- output-jpeg.c 2023-02-07 12:48:20.328740181 -1000
++++ output-jpeg.c.new 2023-02-07 12:50:24.268536252 -1000
+@@ -28,10 +28,16 @@
+
+ #define JZ_CTX_FROM_CINFO(c) (fz_context *)((c)->client_data)
+
++static void fz_jpg_mem_init(j_common_ptr cinfo, fz_context *ctx)
++{
++ cinfo->client_data = ctx;
++}
++
++#define fz_jpg_mem_term(cinfo)
++
+ #else /* SHARE_JPEG */
+
+ typedef void * backing_store_ptr;
+-
+ #include "jmemcust.h"
+
+ #define JZ_CTX_FROM_CINFO(c) (fz_context *)(GET_CUST_MEM_DATA(c)->priv)
+@@ -76,7 +82,7 @@
+ }
+ }
+
+-#endif
++#endif /* SHARE_JPEG */
+
+ #define OUTPUT_BUF_SIZE (16<<10)
+
+@@ -92,6 +98,7 @@
+ {
+ char msg[JMSG_LENGTH_MAX];
+ fz_context *ctx = JZ_CTX_FROM_CINFO(cinfo);
++
+ cinfo->err->format_message(cinfo, msg);
+ fz_throw(ctx, FZ_ERROR_GENERIC, "jpeg error: %s", msg);
+ }